Project

General

Profile

Bug #7636

Impossible to configure printers from GNOME control center

Added by sajolida almost 5 years ago. Updated almost 5 years ago.

Status:
Resolved
Priority:
Elevated
Assignee:
-
Category:
Hardware support
Target version:
Start date:
Due date:
08/11/2014
% Done:

100%

Feature Branch:
bugfix/7636-printers-configuration
Type of work:
Code
Blueprint:
Starter:
No
Affected tool:

Description

In Tails 1.1~rc1 when choosing Applications → System Tools → Preferences
→ System Settings → Printers, the window is greyed out and it is not
possible to add a new printer.


Related issues

Related to Tails - Bug #8443: Adding a new printer requires administration password Resolved 12/15/2014

Associated revisions

Revision ff987ab9 (diff)
Added by Tails developers almost 5 years ago

Install cups-pk-helper (Closes: #7636).

History

#1 Updated by intrigeri almost 5 years ago

  • Category set to Hardware support
  • Target version set to Tails_1.1.1
  • Starter set to No

#2 Updated by intrigeri almost 5 years ago

Confirmed. Note, however, that "Applications -> System Tools -> Administration -> Printing" (aka. system-config-printer) works fine.

Anyway, that's a regression vs. 1.0.1, that only had one place to configure printers, that did work fine.

Installing cups-pk-helper seems to be enough to fix this bug.

#3 Updated by intrigeri almost 5 years ago

  • Subject changed from Impossible to configure printers to Impossible to configure printers from GNOME control center
  • Status changed from Confirmed to In Progress
  • Assignee set to intrigeri
  • % Done changed from 0 to 10
  • Type of work changed from Research to Code

#4 Updated by intrigeri almost 5 years ago

  • Feature Branch set to bugfix/7636-printers-configuration

#5 Updated by intrigeri almost 5 years ago

  • Assignee deleted (intrigeri)
  • % Done changed from 10 to 50
  • QA Check set to Ready for QA

#6 Updated by alant almost 5 years ago

  • Due date set to 08/11/2014
  • Assignee set to alant

#7 Updated by alant almost 5 years ago

  • % Done changed from 50 to 70

Test pases, code review passes, but I was unable to check that the apt repo for that branch is empty as reprepro fails: #7733.

#8 Updated by alant almost 5 years ago

  • Status changed from In Progress to Fix committed
  • Assignee deleted (alant)
  • % Done changed from 70 to 100

Merged, thanks!

#9 Updated by alant almost 5 years ago

  • QA Check changed from Ready for QA to Pass

#10 Updated by anonym almost 5 years ago

  • Status changed from Fix committed to Resolved

#11 Updated by intrigeri over 4 years ago

  • Related to Bug #8443: Adding a new printer requires administration password added

Also available in: Atom PDF