Project

General

Profile

Feature #7591

Unmute and sanitize mixer levels on Jessie

Added by intrigeri over 5 years ago. Updated about 4 years ago.

Status:
Resolved
Priority:
Normal
Assignee:
-
Category:
Hardware support
Target version:
Start date:
07/14/2014
Due date:
% Done:

100%

Feature Branch:
feature/jessie
Type of work:
Code
Blueprint:
Starter:
Yes
Affected tool:

Description

In commit 2fc2715b, we drop alsa-utils -related bits. The corresponding initscript runs sanify_levels_on_card, which might be superseded by PulseAudio on Jessie, or not. We should check that the mixer levels are fine on various hardware (especially that is special-cased by alsa-utils scripts) on startup.

Associated revisions

Revision d0b558f2 (diff)
Added by intrigeri about 4 years ago

Unmute and sanitize ALSA mixer levels at boot time.

This essentially reverts ALSA state handling to pre-Jessie.

For Stretch we might need something better, but it's simple enough that
we could easily turn the relevant bits of the legacy initscript into
a systemd unit file if needed.

Closes: #7591

History

#1 Updated by intrigeri about 5 years ago

  • Starter changed from No to Yes
  1. Get a system thas is handled in a particular way by alsa-utils
  2. Download the latest experimental Tails/Jessie ISO: http://nightly.tails.boum.org/build_Tails_ISO_feature-jessie/
  3. Boot this ISO on that system
  4. Check that the sound levels are OK: if you play music without changing the mixer settings, does it work?
  5. Report back :)

#2 Updated by intrigeri about 5 years ago

  • Assignee set to intrigeri

I'll send a call for testing on -testers@.

#3 Updated by intrigeri almost 5 years ago

  • Status changed from Confirmed to In Progress
  • % Done changed from 0 to 20
  • Type of work changed from Test to Communicate

Sent a call for testing.

#4 Updated by intrigeri over 4 years ago

I've got one report that without alsa-utils, sound level is at 0 after boot and has to be manually raised to get sound output:

00:1b.0 Audio device: Intel Corporation 7 Series/C210 Series Chipset Family High Definition Audio Controller (rev 04)

/proc/asound/cards:
 0 [PCH            ]: HDA-Intel - HDA Intel PCH
                      HDA Intel PCH at 0xc2510000 irq 42

#5 Updated by intrigeri over 4 years ago

intrigeri wrote:

I've got one report that without alsa-utils, sound level is at 0 after boot and has to be manually raised to get sound output:

A single report is not much, but it's hard to know how many people actually tested that => pinged on the -testers@ thread, and tred to get the frontdesk folks to test it too.

#6 Updated by intrigeri over 4 years ago

  • Subject changed from Verify that we don't need alsa-utils anymore on Jessie to Verify that we don't need to sanitize mixer levels anymore on Jessie

Thanks to another report by emmapeel that prompted me to look closer, I noticed that on Jessie, the alsa-utils initscript is explicitly masked (because it is partially replaced with systemd unit files that implement mixer state saving/restoring), so even if we installed the alsa-utils package we would not get the "sanitize mixer levels when state restore fails" feature: it disappeared. Retitling this ticket accordingly.

So, for hardware that has stupid default mixer settings, there are two options:

  1. ideally, such bugs should be fixed in the drivers themselves;
  2. a workaround could be that someone writes a unit file that does the sanitize levels thingie; it needs to only do that if mixer state restore has failed, like the initscript does; this might be trivial, or not.

I could possibly work on the second solution (in Debian proper) if, and only if, I got more reports about regressions on this side: if it's only about rare hardware, then I'm sorry but I have more important things to do, and then those users will need to raise the volume to hear anything (which is a workaround that most users should be able to think of, I guess, so it's not such a big deal).

#7 Updated by intrigeri over 4 years ago

Got a second report (ThinkPad X61):

  • muted on current Tails/Jessie
  • very low default output level on Tails/Wheezy

#8 Updated by intrigeri about 4 years ago

It occurred to me that getting muted mixer levels on startup is a serious problem for users who 1. need the screen reader (they can start it with Alt + Super + S, but with muted mixer levels it's not very useful); and 2. lack hardware buttons to raise volume. The workaround is to blindly click the top-right menu, press the down arrow (to select volume control), and then press the right arrow (to raise volume). I'm not sure yet if documenting the workaround is good enough, or if it's worth trying to fix the actual bug. I'll probably try fixing it, hoping it's easy, and if it isn't we'll see.

#9 Updated by intrigeri about 4 years ago

  • Status changed from In Progress to Resolved
  • % Done changed from 20 to 100

#10 Updated by intrigeri about 4 years ago

  • Subject changed from Verify that we don't need to sanitize mixer levels anymore on Jessie to Unmute and anitize mixer levels on Jessie
  • Assignee deleted (intrigeri)
  • Type of work changed from Communicate to Code

(Retitling to reflect the path I chose in the end. alsa-utils initscript is back.)

#11 Updated by intrigeri about 4 years ago

  • Subject changed from Unmute and anitize mixer levels on Jessie to Unmute and sanitize mixer levels on Jessie

Also available in: Atom PDF