Project

General

Profile

Feature #7564

Bug #7423: Have what we need included in Debian Jessie

Feature #7311: Investigate using GNOME Shell for Jessie

Try GNOME Shell in Jessie or sid with llvmpipe in libvirt/qemu

Added by BitingBird over 5 years ago. Updated over 5 years ago.

Status:
Resolved
Priority:
Normal
Assignee:
Category:
Virtualization
Target version:
Start date:
07/11/2014
Due date:
% Done:

100%

Feature Branch:
Type of work:
Test
Blueprint:
Starter:
No
Affected tool:

Related issues

Related to Tails - Feature #7394: Evaluate xserver-xorg-video-modesetting for KMS support in QEMU and others Resolved 06/11/2014
Related to Tails - Feature #7988: Try GNOME Shell in Jessie or sid on older hardware Resolved 07/11/2014

History

#1 Updated by intrigeri over 5 years ago

  • Tracker changed from Bug to Feature
  • Subject changed from Try gnome-shell in Jessie or sid VM with llvmpipe to Try GNOME Shell in Jessie or sid with llvmpipe
  • Category set to Hardware support

#2 Updated by intrigeri over 5 years ago

  • Parent task set to #7311

#3 Updated by alant over 5 years ago

  • % Done changed from 0 to 10

GNOME shell starts on llvmpipe in sid with libvirt qemu/kvm with spice/qxl. glxinfo | grep renderer outputs Gallium 0.4 on llvmpipe (LLVM 3.4, 128 bits)

#4 Updated by alant over 5 years ago

GNOME shell also starts in sid with libvirt qemu/kvm with spice/cirrus but it doesn't use the KMS driver even though cirrusdrmfb (fb0) is primary device. glxinfo | grep renderer still outputs Gallium 0.4 on llvmpipe (LLVM 3.4, 128 bits).

#5 Updated by intrigeri over 5 years ago

GNOME shell also starts in sid with libvirt qemu/kvm with spice/cirrus but it doesn't
use the KMS driver even though cirrusdrmfb (fb0) is primary
device
.

I think this report belongs to #7394 instead, and probably is caused by the lack of the xserver-xorg-video-modesetting package. Please move this part of the discussion there :)

#6 Updated by intrigeri over 5 years ago

  • Related to Feature #7394: Evaluate xserver-xorg-video-modesetting for KMS support in QEMU and others added

#7 Updated by intrigeri over 5 years ago

Next thing to do IMO: test with llvmpipe on older hardware (e.g. ThinkPad X32 or similar).

#8 Updated by alant over 5 years ago

  • % Done changed from 10 to 20

GNOME Shell works in a jessie guest as well on libvirt/qemu with llvmpipe.

#9 Updated by alant over 5 years ago

  • % Done changed from 20 to 30

Software 3D acceleration works fine in a sid or jessie qemu/kvm guest with QXL/Spice graphics running on a sid host with the following hardware:

  • Intel(R) Core(TM) i5-3210M CPU @ 2.50GHz
  • VGA compatible controller: Intel Corporation 3rd Gen Core processor Graphics Controller (rev 09)
  • OpenGL renderer string: Mesa DRI Intel(R) Ivybridge Mobile

The guest is usable and faster than a Tails 1.0.1 or 1.1 VM on the same host with the same VM parameters. Even opening several tabs in iceweasel and scrolling big pages in the guest doesn't result in a noticable slowness

#10 Updated by intrigeri over 5 years ago

I'm told that it works fine on a X61. I'm unsure if that's with llvmpipe or real hardware support, but it's a useful data-point regarding older hardware.

#11 Updated by intrigeri over 5 years ago

  • Copied to Feature #7988: Try GNOME Shell in Jessie or sid on older hardware added

#12 Updated by intrigeri over 5 years ago

  • Copied to deleted (Feature #7988: Try GNOME Shell in Jessie or sid on older hardware)

#13 Updated by intrigeri over 5 years ago

  • Related to Feature #7988: Try GNOME Shell in Jessie or sid on older hardware added

#14 Updated by intrigeri over 5 years ago

  • Subject changed from Try GNOME Shell in Jessie or sid with llvmpipe to Try GNOME Shell in Jessie or sid with llvmpipe in libvirt/qemu
  • Status changed from Confirmed to Resolved
  • % Done changed from 30 to 100

#15 Updated by intrigeri over 5 years ago

  • Related to deleted (Feature #7988: Try GNOME Shell in Jessie or sid on older hardware)

#16 Updated by intrigeri over 5 years ago

  • Related to Feature #7988: Try GNOME Shell in Jessie or sid on older hardware added

#17 Updated by sajolida over 5 years ago

  • Category changed from Hardware support to Virtualization

Also available in: Atom PDF