Project

General

Profile

Bug #7552

Firefox extension to automatically verify the ISO checksum

Added by sajolida almost 5 years ago. Updated about 1 year ago.

Status:
Resolved
Priority:
Normal
Assignee:
Category:
Installation
Target version:
-
Start date:
01/06/2015
Due date:
% Done:

100%

QA Check:
Feature Branch:
Type of work:
Code
Starter:
No
Affected tool:
ISO Verification Extension

Description

We are planning to create a custom Firefox add-on to download and verify Tails using SHA-256 checksum.


Subtasks

Feature #8564: Design a wireframe of the ISO verification extensionResolved

Feature #8931: Decide if we want to do the verification in the website or in the add-ons menusResolved

Feature #9192: Test installing a Firefox extension that doesn't require restartingResolved

Feature #8565: Have the wireframe of the ISO verification extension reviewed by usability expertsResolved

Feature #8566: Web prototype of "download and verify" pageResolved

Feature #9384: Draft markdown and HTML for "download and verify" pageResolved

Feature #9385: CSS for "download and verify" pageResolved

Feature #9717: Extension: Clarify what happens if download is interruptedResolved

Feature #6664: Try to verify an ISO image using DownThemAllRejectedsajolida

Feature #10519: Fix mentions of Chrome on new download pageResolved

Feature #8567: Write a first version of the ISO verification extensionResolved

Feature #8568: Integrate the ISO verification extension in the web assistant's prototypeResolved

Feature #8569: Have prototype of the ISO verification extension tested by usersResolvedtchou

Feature #10509: Provide an ISO description file for testingResolved

Feature #8570: Release the ISO verification Firefox extension on addons.mozilla.orgResolved

Feature #8849: Technical specifications for ISO verification extensionResolved

Feature #8850: Investigate feasibility of OpenPGP signature verification in JavaScriptRejected

Feature #8816: Investigate upload mechanisms and reactivity for browser app storesResolved

Feature #8855: Design data source for ISO verification extensionResolvedsajolida

Feature #8873: Decide which kind of verification would the ISO verification extension doResolved

Feature #9028: Check whether Tor Browser disables automatic updatesResolvedsajolida

Feature #9043: Check whether BitTorrent clients do proper hash verificationResolved

Feature #9295: Find a name for the download extensionResolvedsajolida

Bug #9387: Browser and extension detection codeResolved

Bug #10525: Make it clear that Firefox 38 is required to use the ISO verification extensionResolved

Feature #10366: Replace /download with a page with the download extensionRejected

Feature #10510: Automate generatation of the ISO descrption file in the release processResolved

Feature #10530: Integrate ISO verification extension in assistantDuplicate

Feature #10533: Adapt ikiwiki setup to ISO Verification Extension and Installation AssistantResolved


Related issues

Related to Tails - Feature #7496: Make it possible to verify the integrity of a Tails USB device In Progress 07/06/2014
Related to Tails - Bug #8531: Port DAVE to Chromium extension Rejected 01/05/2015
Blocked by Tails - Feature #8581: Analyse and simplify the installation and upgrade workflows Resolved 04/07/2014
Blocks Tails - Feature #8822: Package ISO verification Firefox extension for Debian Rejected 01/29/2015

History

#1 Updated by BitingBird almost 5 years ago

  • Assignee set to ma1

Set ma1 as assignee, according to his mail request :)

#2 Updated by intrigeri almost 5 years ago

  • Target version set to Sustainability_M1

(Flagging for 2.0, just like its parent ticket.)

#3 Updated by intrigeri almost 5 years ago

  • Related to Feature #7496: Make it possible to verify the integrity of a Tails USB device added

#4 Updated by BitingBird over 4 years ago

  • Related to Bug #8531: Port DAVE to Chromium extension added

#6 Updated by sajolida over 4 years ago

  • Blocked by Feature #8581: Analyse and simplify the installation and upgrade workflows added

#7 Updated by sajolida over 4 years ago

  • Blocks Feature #8822: Package ISO verification Firefox extension for Debian added

#8 Updated by sajolida over 4 years ago

  • Affected tool set to ISO Verification Extension

#9 Updated by intrigeri almost 4 years ago

sajolida, perhaps it's time to update the milestones for this ticket and maybe a few other ones, so that it's easier (e.g. for people who are waiting to work on #8531, and to people we're telling it's "coming soon") to understand what's the timeline?

#10 Updated by ma1 almost 4 years ago

  • Blueprint changed from https://tails.boum.org/blueprint/download_extension/ to https://tails.boum.org/blueprint/bootstrapping/extension/

As I told sajolida on the public list, while I do hope to have a prototype earlier, a realistic date is the beginning of August.
(Side note: the Blueprint link gave 404, changing it to what I've got).

#11 Updated by sajolida almost 4 years ago

  • Target version changed from Sustainability_M1 to Tails_1.7

#12 Updated by sajolida over 3 years ago

  • Target version changed from Tails_1.7 to Tails_1.8

#13 Updated by ma1 over 3 years ago

I'm currently having a bad time at updating the git repository, looks like my credentials are outdated.

The extension and the sniffing code work fine regarding:

1. certificate pinning
2. UI population from the safe data sources (e.g. download link and hash)
3. asynchronous sha256 verification of arbitrary local files ("I already have an ISO image" link)
4. revealing the verified file in the filesystem explorer (e.g. "Copy image to first USB stick").

What is currently broken is the synchronization with the download manager, but I hope to have it fixed by Monday.

Until I do it and figure out how to update the repo, you can play with both the web page prototype and the extension at

https://maone.net/dev/tails/download.html

and download the sources from

https://maone.net/dev/tails/src/dave-0.0.5.zip

#14 Updated by sajolida over 3 years ago

  • Target version changed from Tails_1.8 to Tails_2.0

#15 Updated by sajolida over 3 years ago

  • Status changed from Confirmed to Resolved
  • Target version deleted (Tails_2.0)

All the subtasks for this are closed now and thhe assistant and the extension were release. So let's close this big ticket. Congrats!

Also available in: Atom PDF