Project

General

Profile

Bug #7505

Video is broken with switchable graphics

Added by alant over 5 years ago. Updated 9 months ago.

Status:
Rejected
Priority:
Low
Assignee:
-
Category:
Hardware support
Target version:
-
Start date:
07/06/2014
Due date:
% Done:

10%

Feature Branch:
bugfix/7505-optimus
Type of work:
Code
Blueprint:
Starter:
No
Affected tool:

Description

On a MacBook Pro 6,2, which has both an intel and nvidia graphics card Tails 1.1-rc1 boots fine but X fails to start.

It is possible to make it work by booting with i915.modeset=0 rootpw=pass and drop a file containing:

Section "Device" 
    Identifier "Device0" 
    Driver "nouveau" 
    BusID "1:0:0" 
EndSection

and restart X with service gdm3 restart


Related issues

Related to Tails - Bug #9224: Document that video is broken with double-video-card Mac hardware Resolved 04/10/2015
Related to Tails - Bug #11145: GNOME freezes with Intel HD GPU (3rd Gen) Duplicate 02/20/2016
Related to Tails - Bug #9089: No support for switchable IGP/GPU Rejected 03/22/2015
Blocked by Tails - Feature #8183: Ship a 64-bit (x86_64) instead of 32-bit userspace Resolved 10/11/2016

Associated revisions

Revision a25d38c5 (diff)
Added by intrigeri over 3 years ago

Install bumblebee and bbswitch-dkms for Optimus graphics support.

refs: #7505, #11445

History

#1 Updated by mguiraud over 5 years ago

Also
these Mac Book models have dual graphics processors and may have the same issue :
MacBookPro 5,1 - MacBook Pro (15-inch, Late 2008)
MacBookPro 5,2 - MacBook Pro (17-inch, Early 2009)
MacBookPro 5,3 - MacBook Pro (15-inch, 2.53GHz, Mid 2009)
MacBookPro 6,1 - MacBook Pro (17-inch, Mid 2010)
MacBookPro 6,2 - MacBook Pro (15-inch, Mid 2010)
MacBookPro 8,3 - MacBook Pro (17-inch, Early 2011)
MacBookPro 8,2 - MacBook Pro (15-inch, Early 2011)
MacBookPro 9,1 - MacBook Pro (15-inch, Mid 2012)
MacBookPro 10,1 - MacBook Pro (Retina, Mid 2012)

#2 Updated by BitingBird over 5 years ago

  • Category set to Hardware support

#3 Updated by BitingBird over 5 years ago

It would be interesting to know if it works with Debian.

#4 Updated by intrigeri over 5 years ago

I would be surprised if there wasn't a way to disable the graphics adapter that shouldn't been used, on the kernel cmdline.

#5 Updated by sajolida over 5 years ago

New MacbookPro are dual-GPU, they have an integrated and a discrete GPU.

According to WhisperBack report 7c8517875e5945220714fe6ea9112211,
MacBookPro10,1 Retina, Tails doesn't work in the default setup, but
works if forced to start with the integrated GPU only.

This person used a third party application, http://gfx.io/, to force integrated only through OS X, and then reboot in that special mode that works with Tails.

This workaround suggests that a solution might be found outside of Tails...

#6 Updated by intrigeri over 5 years ago

This workaround suggests that a solution might be found outside of Tails...

I suspect that Ubuntu may have solutions to this problem, that could possibly be ported to Debian.

#7 Updated by indolering almost 5 years ago

I wanted to confirm that I ran into a similar issue on a "MacBook Pro 15-inch, Early 2011" with a dual graphics card setup.

Specifically, the boot process got past the loading bars and the laptop was on but the screen was blank. Booting using the failsafe option got me to a command line. I have another laptop so I didn't go any further.

I would be happy to test a fix or workaround. I know my way around the command line, but please include step-by-step instructions.

#8 Updated by mguiraud over 4 years ago

The GFX fix doesn't work for my MacBookPro 6,2. I sat up my card with the integrated GPU. I got the blinking cursor.

How should I do to access the prompt and change the graphic file.
And, BTW wich file is this ?

#9 Updated by BitingBird over 4 years ago

  • Related to Bug #9224: Document that video is broken with double-video-card Mac hardware added

#10 Updated by BitingBird over 4 years ago

It should be tested to see if that's still the case in Tails/Jessie.

#11 Updated by BitingBird over 4 years ago

  • Assignee set to sajolida
  • Target version set to Tails_1.4.1
  • % Done changed from 0 to 30
  • QA Check set to Ready for QA

Created a dedicated section (I thought it only affected Mac computers, but intri says others are in the same case). Added the 2 workarounds. Please review :)

#12 Updated by BitingBird over 4 years ago

  • Assignee deleted (sajolida)
  • Target version deleted (Tails_1.4.1)
  • QA Check deleted (Ready for QA)

Oops, wrong ticket.

#13 Updated by BitingBird over 4 years ago

  • % Done changed from 30 to 0

#14 Updated by intrigeri almost 4 years ago

  • Related to Bug #11145: GNOME freezes with Intel HD GPU (3rd Gen) added

#15 Updated by intrigeri over 3 years ago

  • Feature Branch set to bugfix/7505-optimus

#16 Updated by intrigeri over 3 years ago

  • Subject changed from Video is broken on dual-graphics-card apple hardware to Video is broken with switchable graphics

#17 Updated by intrigeri over 3 years ago

  • Status changed from Confirmed to In Progress
  • Assignee set to intrigeri
  • Target version set to Tails_2.6
  • % Done changed from 0 to 10

I have something that boots and apparently has the needed bits, let's wait for an ISO to be online and then point testers to it.

#18 Updated by intrigeri over 3 years ago

Regression on ThinkPad T540p:

  • booted fine 2.4~rc1;
  • with this branch it fails to start X (tried bbswitch.load_state=1, i915.modeset=0, failsafe mode); I see kernel messages about i915, nothing about nouveau, bbswitch says it has disabled the discrete graphics card, and X.Org tries to use the QXL (!) driver.

#19 Updated by intrigeri over 3 years ago

Sent a call for testing to tails-testers@.

#20 Updated by intrigeri over 3 years ago

Regression on ThinkPad T540p:

That's due to #11514.

#21 Updated by intrigeri over 3 years ago

No regressions on this hardware without switchable graphics:

  • HP Elitebook 2540p
  • Samsung NC10

Looks like I may manage to get test results about the Lenovo Thinkpad T540p (that has switchable graphics) soonish.

#22 Updated by intrigeri over 3 years ago

  • Related to Bug #9089: No support for switchable IGP/GPU added

#23 Updated by intrigeri over 3 years ago

  • Target version deleted (Tails_2.6)
  • Type of work changed from Research to Code

This topic branch now has merge conflicts with devel, since the branch for #10298 was merged in there. They are non-trivial to fix: building dkms modules for the amd64 kernel is quite painful due to multiarch. Also, I got basically no feedback from the people who I was doing this work for (MacBook & powerful ThinkPad users), which does not help motivating me to work on this further right now. Once we have #8183 it'll be easy to fix the modules compilation problem, so I'll work on it again once we have a 64-bit userland, but not earlier. If someone wants to work on it earlier, feel welcome to reassign to you :)

#24 Updated by intrigeri over 3 years ago

  • Blocked by Feature #8183: Ship a 64-bit (x86_64) instead of 32-bit userspace added

#25 Updated by intrigeri about 3 years ago

  • Priority changed from Normal to Low
  • Target version set to Tails_3.0

Now that we have #8183 it's easier to come back to this. I'll try to do it for 3.0, not a blocker though.

#26 Updated by intrigeri almost 3 years ago

intrigeri wrote:

Now that we have #8183 it's easier to come back to this.

Merged feature/stretch into the topic branch, let's see.

#27 Updated by intrigeri over 2 years ago

  • Target version deleted (Tails_3.0)

#28 Updated by intrigeri almost 2 years ago

See the discussion on bug report: 67fce74fdbe7ef2b01cf14958ae8ba3a for more info on another instance of this bug (HP ZBook 15 G3, Intel Corporation HD Graphics 530 + NVIDIA Corporation GM107GLM [Quadro M2000M]).

#29 Updated by goupille over 1 year ago

another user reported what looks like the same issue on a Dell XPS with an Intel(R) HD Graphics 630 and a NVIDIA GeForce GTX 1050. The user didn't get a black screen tho, but the "Error starting GDM with your graphic cars: Intel corporation device..." screen.

it is not possible to disable one of the GPU in the BIOS on Dell XPS, so no "easy" workaround...

#30 Updated by intrigeri 9 months ago

  • Status changed from In Progress to Rejected
  • Assignee deleted (intrigeri)

This ticket is of the kind that won't ever be closed, and is hardly actionable:

  • It's scope is much too broad: there are many kinds of switchable graphics nowadays (and I bet some of them work just fine in Tails).
  • There's nothing we can do ourselves about it, apart of shipping and updating required software & drivers.

Besides, the problem is documented as a known issue.

So let's close this one and open new tickets for specific situations, when there's a known candidate solution in Debian that we could try shipping.

Also available in: Atom PDF