Project

General

Profile

Bug #7470

Feature #7226: Document the "New identity" feature in the browser

Update warning on new identity now that this feature exists in the browser

Added by sajolida almost 6 years ago. Updated about 5 years ago.

Status:
Resolved
Priority:
Normal
Assignee:
-
Category:
-
Target version:
-
Start date:
06/29/2014
Due date:
% Done:

100%

Feature Branch:
doc/7226-torbrowser_new_identity
Type of work:
End-user documentation
Blueprint:
Starter:
No
Affected tool:

Description

Our warning:

https://tails.boum.org/doc/about/warning/index.en.html#identities

only mentions the new identity feature of Vidalia. Now that the browser also has a new identity feature, at least the part related to cookies should be rewritten.

Associated revisions

Revision 7a662ebc
Added by Tails developers about 5 years ago

Merge remote-tracking branch 'origin/doc/7226-torbrowser_new_identity'

Closes: #7470, #7709, #7226

History

#1 Updated by BitingBird over 5 years ago

  • Status changed from Confirmed to In Progress
  • QA Check set to Ready for QA

#2 Updated by BitingBird over 5 years ago

  • Assignee set to sajolida
  • Target version set to Tails_1.2.2
  • Feature Branch set to bitingbird:doc/7470-new_identity_warning

#3 Updated by sajolida over 5 years ago

  • Assignee changed from sajolida to BitingBird
  • QA Check changed from Ready for QA to Info Needed

Thanks for the patch. Could you be more precise when saying "It removes some cookies but not always all." which is very vague? I suggest to check the design documents of TBB regarding this.

#4 Updated by sajolida over 5 years ago

  • Related to Feature #7226: Document the "New identity" feature in the browser added

#5 Updated by anonym over 5 years ago

  • Target version changed from Tails_1.2.2 to Tails_1.2.3

#6 Updated by BitingBird over 5 years ago

They have only a draft of design document: https://www.torproject.org/projects/torbrowser/design/#new-identity

I said "not always all" because of: "If the user chose to "protect" any cookies by using the Torbutton Cookie Protections UI, those cookies are not cleared as part of the above.", but maybe we can just ignore this case. Not sure.

#7 Updated by intrigeri over 5 years ago

They have only a draft of design document: https://www.torproject.org/projects/torbrowser/design/#new-identity

I thought that the Tor Browser short user manual might be another good source of inspiration, but it doesn't tell anything about the new identity feature.

I said "not always all" because of: "If the user chose to "protect" any cookies by using the Torbutton Cookie Protections UI, those cookies are not cleared as part of the above.", but maybe we can just ignore this case. Not sure.

Good catch. How about "It clears cookies that were not manually protected.", then?

#8 Updated by BitingBird over 5 years ago

Your formulation is more precise and doesn't lose information, so it's definitly better. I'll propose an update to my branch.

#9 Updated by intrigeri over 5 years ago

  • QA Check changed from Info Needed to Dev Needed

#10 Updated by sajolida over 5 years ago

I feel that "manually protected" uses plain language to refer to a quite precise feature. I find it more clear to mention that feature explicitly.

So I would prefer saying something like "It removes all cookies except those protected by the Cookie Protection feature".

#11 Updated by BitingBird about 5 years ago

  • Target version changed from Tails_1.2.3 to Tails_1.3

#12 Updated by BitingBird about 5 years ago

  • Assignee changed from BitingBird to sajolida
  • QA Check changed from Dev Needed to Ready for QA

Moved the warning to Vidalia's page and made a joined warning (linking to both TBB and vidalia pages) saying that "new identity" should not be trusted.

Please review :)

#13 Updated by intrigeri about 5 years ago

  • Feature Branch changed from bitingbird:doc/7470-new_identity_warning to doc/7470-new_identity_warning

Rebased on master.

#14 Updated by BitingBird about 5 years ago

Built, it works. Added a commit to remove a forgotten useless word.

#15 Updated by intrigeri about 5 years ago

  • % Done changed from 0 to 50

BitingBird wrote:

Built, it works. Added a commit to remove a forgotten useless word.

Cherry-picked on top of doc/7470-new_identity_warning.

#16 Updated by sajolida about 5 years ago

  • Feature Branch changed from doc/7470-new_identity_warning to doc/7226-torbrowser_new_identity

This branch had unrelated commits (probably based on other topic branches that are not merged yet), so I cherry-picked your relevant commits (463b9d7 cb6749e 7458122) in doc/7226-torbrowser_new_identity (which should be treated at the same time) and I'll ignore doc/7470-new_identity_warning.

#17 Updated by sajolida about 5 years ago

  • Related to deleted (Feature #7226: Document the "New identity" feature in the browser)

#18 Updated by sajolida about 5 years ago

  • Parent task set to #7226

Marking this as a subtask of #7226 as we'll do that together.

#19 Updated by sajolida about 5 years ago

  • Assignee deleted (sajolida)
  • Target version deleted (Tails_1.3)
  • QA Check deleted (Ready for QA)

Let's only track progress, assignee, and target version on the parent task, shall we?

#20 Updated by Tails about 5 years ago

  • Status changed from In Progress to Resolved
  • % Done changed from 50 to 100

Applied in changeset commit:44b8986096ba4816d20bbd310ecf4cc9f29d853e.

Also available in: Atom PDF