Project

General

Profile

Bug #7462

isohybrid command returns warnings on Tails 1.1

Added by sajolida over 5 years ago. Updated about 5 years ago.

Status:
Resolved
Priority:
Elevated
Assignee:
-
Category:
Installation
Target version:
Start date:
07/31/2014
Due date:
% Done:

100%

Feature Branch:
doc/7462-new-isohybrid-options
Type of work:
Research
Blueprint:
Starter:
No
Affected tool:

Description

isohybrid tails-i386-1.1~beta1.iso --entry 4 --type 0x1c returns:

isohybrid: Warning: more than 1024 cylinders: 1045
isohybrid: Not all BIOSes will be able to boot this device

Do we have to adapt the isohybrid command from the documentation for Tails 1.1?


Subtasks

Feature #7692: Investigate where the new isohybrid warnings come fromResolvedintrigeri


Related issues

Related to Tails - Feature #7706: Better compress the SquashFS in the ISO Resolved 07/31/2014
Related to Tails - Bug #7370: Tell the user that isohybrid modifies the ISO image Resolved 06/03/2014
Related to Tails - Bug #12146: Tails installed using dd is not seen as a bootable device on MacBook Pro Resolved 12/08/2017

History

#1 Updated by intrigeri over 5 years ago

isohybrid tails-i386-1.1~beta1.iso --entry 4 --type 0x1c returns:

isohybrid: Warning: more than 1024 cylinders: 1045
isohybrid: Not all BIOSes will be able to boot this device

What's the version of isohybrid being used?

Are these messages mere warnings, or fatal errors? In other words: 1. once the ISO is cat'ed on a device, does it actually boot? 2. is the ISO file modified in the process?

#2 Updated by sajolida over 5 years ago

  • Priority changed from Elevated to Normal
  • Target version deleted (Tails_1.1)

I meant to correct myself, but you were faster... Those are warnings: the ISO is modified, and the resulting USB stick can boot Tails 1.1~beta1 fine. The version of isohybrid is 0.12.

So I'm lowering the priority to normal and removing target version, but still I guess that this will confuse many people.

#3 Updated by sajolida over 5 years ago

  • Subject changed from isohybrid command fails on Tails 1.1~beta1 to isohybrid command returns warnings on Tails 1.1~beta1
  • Assignee deleted (intrigeri)

#4 Updated by intrigeri over 5 years ago

Maybe we could simply redirect stdout/stderr/whatever to /dev/null.

#5 Updated by sajolida over 5 years ago

  • Category set to Installation

#6 Updated by intrigeri over 5 years ago

  • Status changed from New to Confirmed

#7 Updated by sajolida over 5 years ago

  • Assignee set to sajolida

#8 Updated by BitingBird about 5 years ago

Well, I have some users who have this error and the USB doesn't boot.

#9 Updated by intrigeri about 5 years ago

  • Subject changed from isohybrid command returns warnings on Tails 1.1~beta1 to isohybrid command returns warnings on Tails 1.1

#10 Updated by intrigeri about 5 years ago

  • Priority changed from Normal to Elevated
  • Target version set to Tails_1.1.1

If it causes boot failures, then it's a more severe regression that what I thought. Bumping priority, tentatively flagging for 1.1.

#11 Updated by intrigeri about 5 years ago

The tests run as part of #7692 showed that these warnings are caused by the increase of the size of our ISO. Now, it might be that some other combination of options passed to isohybrid break the boot on less systems. Hence:

  1. sent a call for testing on -testers@ and -dev@;
  2. asked for advice on the syslinux mailing-list.

#12 Updated by intrigeri about 5 years ago

What I gathered already:

  • --entry 4 --type 0x1c was meant to support BIOS'es that only boot from USB in USB-Zip mode; these BIOS'es were said to be ancient... in 2009; presumably, systems with such a BIOS can't boot Tails anyway;
  • -h 255 -s 63 is said to be the second best combination of options, and it's needed for > 1 GiB ISO images. Indeed, with these options, isohybrid doesn't print any warning when run on the Tails 1.1 ISO. I'm said that this allows "to get the maximum cylinder size of a bit less than 8 MiB. This will suffice for ISOs up to nearly 8 GiB".

#13 Updated by intrigeri about 5 years ago

  • Related to Feature #7706: Better compress the SquashFS in the ISO added

#14 Updated by intrigeri about 5 years ago

I think we should:

  1. Short-term workaround: modify the doc to suggest the aforementioned options (replacing --entry 4 --type 0x1c with -h 255 -s 63) in case the current ones don't work.
  2. Then:
    • if the feedback we get from the call for testing and/or my reasoning above makes us confident enough to change the isohybrid options, then do it;
    • else, get #7706 fixed in 1.1.1 to workaround the problem.

#15 Updated by intrigeri about 5 years ago

Short-term workaround: modify the doc to suggest the aforementioned options (replacing --entry 4 --type 0x1c with -h 255 -s 63) in case the current ones don't work.

I had a look, and it doesn't seem easy to adapt the manual installation doc this way: once one has followed the documented steps, their ISO is modified and can't be used to test another combination of isohybrid options. As a short-term fix (unless we're bold enough to change the isohybrid options right ahead in the doc, without waiting for testing feedback, which I'm almost tempted to do), maybe Tails does not start could advice to download a fresh ISO, and follow the manual installation process again, except the changed isohybrid options.

sajolida, what do you think?

#16 Updated by sajolida about 5 years ago

Well, I have some users who have this error and the USB doesn't boot.

I haven't identified things like this on tails-bugs@ since the release.

But quite a few people had problems booting Tails 1.1 due to a bad
download or a regression in the support of their graphic card. That
could as well be the case here.

So, how far did you investigate the problem on those USB sticks not
booting? What boot problem where they experiencing?

#17 Updated by intrigeri about 5 years ago

I haven't identified things like this on tails-bugs@ since the release.

Yes, that was also my impression, and it made me unsure that we had a problem in the beginning. Just for the record: tails-bugs@ sees less traffic than IRC.

So, how far did you investigate the problem on those USB sticks not booting? What boot problem where they experiencing?

People doing intensive support on IRC, such as bitingbird, will know better than me.

All that I was told is something along the lines of "for quite a few users, only DVD + clone'n'install works", which tends to confirm that there's a problem with isohybrid, and is no big surprise considering 1. the warning it displays; and 2. the replies I got on the syslinux mailing-list from experts in this area ("-h 255 -s 63 is said to be the second best one. Needed for > 1 GiB"), that personally I won't argue against.

Given all this, I personally need neither more info from bug reporters, nor to see the problem myself, to be convinced that we actually do have a problem.

#18 Updated by sajolida about 5 years ago

I had a look, and it doesn't seem easy to adapt the manual installation doc this way: once one has followed the documented steps, their ISO is modified and can't be used to test another combination of isohybrid options. As a short-term fix (unless we're bold enough to change the isohybrid options right ahead in the doc, without waiting for testing feedback, which I'm almost tempted to do), maybe Tails does not start could advice to download a fresh ISO, and follow the manual installation process again, except the changed isohybrid options.

sajolida, what do you think?

And also after doing isohybrid people can't verify the ISO image again
anymore. So what about advising them to do a backup of the ISO image, and
explain that it will be modified by this command?

#19 Updated by intrigeri about 5 years ago

And also after doing isohybrid people can't verify the ISO image again
anymore. So what about advising them to do a back of the ISO image, and
explain that it will be modified by this command?

Yes. That's related to #7370.

#20 Updated by intrigeri about 5 years ago

FTR, I've just nominated #7706 for 1.1.1, and hope Alan will merge it tomorrow, in the hope that it fixes the root cause of this problem as a stop-gap for now: I've still received no test reports regarding the new isohybrid options, so I'm less and less sure we'll find a good solution to this problem via documentation changes in time for 1.1.1. (Still, documenting workarounds now would still make sense IMO.)

#21 Updated by sajolida about 5 years ago

  • Related to Bug #7370: Tell the user that isohybrid modifies the ISO image added

#22 Updated by sajolida about 5 years ago

  • Assignee deleted (sajolida)
  • QA Check set to Ready for QA
  • Feature Branch set to doc/7462-new-isohybrid-options

As a first step, I documented this as a known issue.

#23 Updated by intrigeri about 5 years ago

  • Status changed from Confirmed to In Progress

#24 Updated by intrigeri about 5 years ago

  • Assignee set to sajolida

Merged into master, sent an improvement suggestion on tails-dev@. sajolida, do you want to take care of the next steps?

#25 Updated by intrigeri about 5 years ago

  • QA Check changed from Ready for QA to Dev Needed

(Marking as dev needed, since the first step that was implemented, although much welcome, is far from being a real solution.)

#26 Updated by sajolida about 5 years ago

  • Assignee changed from sajolida to intrigeri
  • QA Check changed from Dev Needed to Ready for QA

#27 Updated by intrigeri about 5 years ago

  • Assignee changed from intrigeri to sajolida
  • QA Check changed from Ready for QA to Dev Needed
  • Feature Branch deleted (doc/7462-new-isohybrid-options)

(Dropping the topic branch indication, that was about the first step.)

#28 Updated by intrigeri about 5 years ago

Mitigated with #7706 being done for 1.1.1, but that's only a short-term fix: I wouldn't be surprised if we hit the 1GB limit by the end of the year, for some reason.

Pinged on the call for testing wrt. new isohybrid options, no answer so far... if we get no more testing results, then I think we should go ahead and change the doc anyway at some point. I'll come back to it in a week or two.

#29 Updated by sajolida about 5 years ago

  • Assignee changed from sajolida to intrigeri
  • QA Check changed from Dev Needed to Info Needed

In case we finally decide to replace the old options with the new ones, I updated the branch doc/7462-new-isohybrid-options to do that. Feel free to merge it if you think that's needed.

I also dropped the known issue all the way, and don't document the old options anymore. If you think it's worth keeping that, feel free to revert 4cb164e and assign that ticket to me again, and I polish all that.

I'm now reassign this to you either to bring more info, either to review it.

#30 Updated by intrigeri about 5 years ago

In case we finally decide to replace the old options with the new ones, I updated the branch doc/7462-new-isohybrid-options to do that.

Great, thanks! I've looked at it, and it looks good.

I'm now reassign this to you either to bring more info, either to review it.

OK. I'll wait a few more days, in the hope that my last ping on the call for testing finally produces results, and if I see no regression reported, then I'll merge into master.

#31 Updated by intrigeri about 5 years ago

Test report on macbook pro 9,2: no regression with syslinux 3:6.03~pre18+dfsg-1~bpo70+1. The old options worked fine already.

#32 Updated by intrigeri about 5 years ago

  • Feature Branch set to doc/7462-new-isohybrid-options

#33 Updated by intrigeri about 5 years ago

  • Status changed from In Progress to Resolved
  • Assignee deleted (intrigeri)
  • QA Check changed from Info Needed to Pass

Merged, the new options are now live on the website. Thanks again!

#34 Updated by intrigeri over 2 years ago

  • Related to Bug #12146: Tails installed using dd is not seen as a bootable device on MacBook Pro added

Also available in: Atom PDF