Project

General

Profile

Feature #7438

Feature #10491: Redesign the network configuration and startup

Design a progress indicator until Tor is ready

Added by u over 5 years ago. Updated over 2 years ago.

Status:
Duplicate
Priority:
Normal
Assignee:
-
Category:
-
Target version:
-
Start date:
06/22/2014
Due date:
% Done:

0%

Feature Branch:
Type of work:
User interface design
Blueprint:
Starter:
No
Affected tool:

Description

suggestion by sajolida:
Maybe something like this VPN indicator, replacing the padlock with an
onion: https://wiki.gnome.org/Projects/GnomeShell/Design/Research/StatusIndicators#Network-3


Related issues

Related to Tails - Bug #7721: "Tor is ready" notification sometimes appears before the end of time synchronization Resolved 08/02/2014
Blocks Tails - Feature #7440: Implement a progress indicator while establishing a connection to Tor Duplicate 06/22/2014

Associated revisions

Revision 2f8baf70 (diff)
Added by intrigeri about 4 years ago

Don't tell the user that "Tor is ready" before htpdate is done.

There are two possible problems with using Tor before the time is
correct enough:

1. We want all Tails users to have very similar clocks, as part of the
protection against fingerprinting Tails tries to provide;
2. Accessing hidden services can be problematic when one's clock is not
correct; hence the notification we display about
time synchronization.

Closes: #7721
Refs: #7438

History

#1 Updated by intrigeri over 5 years ago

  • Blocks Feature #7440: Implement a progress indicator while establishing a connection to Tor added

#2 Updated by intrigeri over 5 years ago

  • Subject changed from Design a progress indicator to Design a progress indicator while establishing a connection to Tor

#3 Updated by sajolida over 5 years ago

Actually, having a progress bar, like in the Tor launcher would be even
better.

Especially on crappy connections to know if it's worth waiting :)

#4 Updated by intrigeri over 5 years ago

I'm unsure about having progress information about connecting to the Tor network only: even once Tor is ready, at least for some usecases, one also needs to wait for the time to have been synchronized. So, I'm tempted to rephrase this ticket into "Design a progress indicator while establishing a fully-working Internet connection", which would cover both (and anything else that the user is supposed to wait for before attempting to connect to online services). Thoughts?

#5 Updated by sajolida over 5 years ago

That makes sense to me. But maybe there is only a misunderstanding on
terminology here, as for me "a connection to Tor" is established once
the "Tor is ready" notification appeared. And that is already after time
synchronization.

But maybe I missed something, could you clarify what else do you mean by
"anything else that the user is supposed to wait for before attempting
to connect to online services"?

#6 Updated by intrigeri over 5 years ago

That makes sense to me.

OK, good.

But maybe there is only a misunderstanding on terminology here, as
for me "a connection to Tor" is established once the "Tor is ready"
notification appeared. And that is already after
time synchronization.

Yes and no: it's after the initial rough time synchronization (via the Tor consensus), but when "Tor is ready", the finer-grained htpdate time sync' process is still running, and the user is shown a notification that tells them "Synchronizing the system's clock" and "Tor needs an accurate clock to work properly, especially for Hidden Services. Please wait..." until htpdate is done.

#7 Updated by sajolida over 5 years ago

  • Subject changed from Design a progress indicator while establishing a connection to Tor to Design a progress indicator until Tor is ready

In the tests I did the notification about time sync disappeared way before the "Tor is ready notification", but indeed there was sometimes still an htpdate process running in the background.

I didn't know that even when the "Tor is ready" notification appeared, Tor was not "fully-working" in some cases... Nitpicking aside, can this have concrete implications for the user in terms of usability?

- If so, then maybe the "Tor is ready" notification needs to be fixed to appear only when "ready" means "fully-working".
- Otherwise, a progress bar until this notification appears would be enough I guess.

Anyway, I think the idea here is to match the end of the progress bar with the "Tor is ready" notification.

#8 Updated by intrigeri over 5 years ago

I didn't know that even when the "Tor is ready" notification appeared, Tor was not "fully-working" in some cases... Nitpicking aside, can this have concrete implications for the user in terms of usability?

I think there are two possible problems with using Tor before the time is correct:

  1. we want all Tails users to have the same clock, as part of the protection against fingerprinting Tails tries to provide;
  2. IIRC, accessing hidden services can be problematic when one's clock is not correct; the notification we display tends to confirm my (poor) memory; sadly, I don't remember the details.

- If so, then maybe the "Tor is ready" notification needs to be fixed to appear
only when "ready" means "fully-working".

Yes, probably.

Anyway, I think the idea here is to match the end of the progress bar with the "Tor is ready" notification.

Agreed.

#9 Updated by sajolida over 5 years ago

  • Related to Bug #7721: "Tor is ready" notification sometimes appears before the end of time synchronization added

#10 Updated by intrigeri about 5 years ago

  • Status changed from New to Confirmed

#11 Updated by u over 4 years ago

  • Related to Feature #9002: Replace Vidalia's green onion feature added

#12 Updated by u over 4 years ago

  • Related to deleted (Feature #9002: Replace Vidalia's green onion feature)

#13 Updated by u over 2 years ago

  • Status changed from Confirmed to Resolved

I think we do now have such an indicator as part of OnionCircuits. This indicator could be improved, so that, when people hover it with their mouse they get the "Tor is not ready." notification bubble. I'll open another ticket for this proposal.

#14 Updated by u over 2 years ago

  • Parent task deleted (#7437)

#15 Updated by u over 2 years ago

  • Parent task set to #10491

#16 Updated by sajolida over 2 years ago

  • Status changed from Resolved to Duplicate

I'll instead mark this as a duplicate of #10491. We're talking here about progress indication which Onion Circuits doesn't provide: it only provides a binary "ready/not ready" indication but no information about the progress in itself.

Also available in: Atom PDF