Project

General

Profile

Feature #7437

Consider adding a progress indicator while establishing a connection to Tor

Added by u over 5 years ago. Updated over 2 years ago.

Status:
Duplicate
Priority:
Normal
Assignee:
-
Category:
-
Target version:
-
Start date:
06/22/2014
Due date:
% Done:

0%

Feature Branch:
Type of work:
User interface design
Blueprint:
Starter:
No
Affected tool:

Description

Beware! You're probably looking for #10491 instead.

Team: sajolida, tchou, ? (coder), ? (reviewer)

This is an outcome of the 1st UX session at NUMA.

Problem:

We are on a captive portal and need to launch the insecure browser to connect to the network.

The user knows that she needs to wait for something to happen before she can browse securely, but a first-time user wouldn't have this information, nor would he know how long the wait will last (which can be a problem even for an experienced user)

The experts recommend:

In general when something needs to happen before a user can do something else it is advisable to let the user know: a) what needs to
happen and b) how long this is going to take.

A quick fix for this could be to display some progress bar/wheel in the status bar that indicates that Tor is connecting, initially you can also couple this with a tooltip message along the lines of "Establishing Tor secure connection" with a smaller "do not show this anymore" button/link to kill the tooltip.

Sajolida comments:

Good catch. The time between the clock synchronization and Vidalia showing up can be quite long on a slow connection and having some visual feedback would be really great. More stuff in the Network-Manager hooks, yeah!

And actually, having a progress indicator while Tor is starting makes even more sense that having the notification about synchronizing the system clock (which is only part of that process). Especially since the clock synchronization won't affect the hardware clock. We've receive user support request wondering if this clock synchronization could reveal whether they used Tails on that computer. So superseding it might be worth considering.


Related issues

Related to Tails - Feature #5785: Detect captive portals Confirmed 09/26/2014
Related to Tails - Feature #9002: Replace Vidalia's green onion feature Resolved 03/03/2015
Related to Tails - Feature #8825: Provide default bridges Confirmed 01/30/2015
Related to Tails - Feature #13274: Consider adding a popup to OnionCircuits notifcation area while Tor is not ready Confirmed 06/30/2017

History

#1 Updated by tchou over 5 years ago

#2 Updated by intrigeri about 5 years ago

  • Status changed from New to Confirmed

#3 Updated by u over 4 years ago

  • Related to Feature #9002: Replace Vidalia's green onion feature added

#4 Updated by sajolida over 4 years ago

  • Description updated (diff)
  • Target version set to 2016

#5 Updated by sajolida over 4 years ago

  • Description updated (diff)

#6 Updated by intrigeri about 4 years ago

#7 Updated by sajolida about 4 years ago

  • Related to Feature #10491: Redesign the network configuration and startup added

#8 Updated by anonym over 3 years ago

Name suggestion: Alligator

#10 Updated by Dr_Whax about 3 years ago

  • Target version changed from 2016 to 2018

#11 Updated by Dr_Whax about 3 years ago

  • Target version deleted (2018)

#12 Updated by intrigeri almost 3 years ago

  • Description updated (diff)

(I find it confusing to have this set of tickets left around, while #10491 was created and is kept more up-to-date.)

#13 Updated by u over 2 years ago

  • Related to Feature #13274: Consider adding a popup to OnionCircuits notifcation area while Tor is not ready added

#14 Updated by u over 2 years ago

In the description we said: "Good catch. The time between the clock synchronization and Vidalia/OnionCircuits showing up can be quite long on a slow connection and having some visual feedback would be really great."

I think that OnionCircuits nowadays displays a little cross and then displays a notification when ready. I propose in #7439 to simply change the message displayed by the clock instead of overengineering a technical solution.

#15 Updated by u over 2 years ago

  • Related to deleted (Feature #10491: Redesign the network configuration and startup)

#16 Updated by u over 2 years ago

  • Subject changed from Add a progress indicator while establishing a connection to Tor to Consider adding a progress indicator while establishing a connection to Tor

#17 Updated by u over 2 years ago

  • Status changed from Confirmed to Duplicate

I'm closing this as a dpublicate of #10491. All new progress on this matter is tracked there.

Also available in: Atom PDF