Project

General

Profile

Feature #7434

Feature #7433: Turn Tails OpenPGP Applet into a standalone application

Design a main window for Tails OpenPGP Applet when used as a standalone application and not an applet

Added by Anonymous over 5 years ago. Updated about 2 years ago.

Status:
Duplicate
Priority:
Normal
Assignee:
-
Category:
-
Target version:
-
Start date:
06/22/2014
Due date:
% Done:

0%

Feature Branch:
Type of work:
User interface design
Blueprint:
Starter:
No
Affected tool:
OpenPGP Applet

Description

Design a main window for Tails OpenPGP Applet when used as a standalone application and not an applet

History

#1 Updated by BitingBird over 5 years ago

  • Blocks Feature #7435: Add Tails OpenPGP Applet to the Applications menu added

#2 Updated by intrigeri over 5 years ago

What would be the usecase(s) satisfied by this "main window"?

#3 Updated by Anonymous over 5 years ago

  • QA Check set to Info Needed

I'll let sajolida answer this?

#4 Updated by BitingBird over 5 years ago

  • Assignee set to sajolida

#5 Updated by sajolida over 5 years ago

What would be the usecase(s) satisfied by this "main window"?

I'm not sure to understand to scope of your question.

I'm not thinking about any use case that would be different than the
applet itself for this window but if we want to add it the the menus,
then this launcher has to start something. That's what I call main window.

According to the report from the UX testing, someone had to fallback on
using gpg from the terminal because he didn't find our applet.

I admit he probably didn't read our doc. But currently you can't really
know that this applet does GPG stuff unless you read the doc, or check
its About page. The interface of the applet itself doesn't mention OpenPGP.

So having a menu would be a good step towards making it easier to
discover that there is a dedicated application to do OpenPGP in Tails.

#6 Updated by intrigeri over 5 years ago

I'm not thinking about any use case that would be different than the
applet itself for this window but if we want to add it the the menus,
then this launcher has to start something. That's what I call main window.

So, the "main window" should expose the same set of features as the applet?

#7 Updated by sajolida over 5 years ago

So, the "main window" should expose the same set of features as the applet?

I'd say so...

#8 Updated by BitingBird over 5 years ago

  • Status changed from New to Confirmed
  • Assignee deleted (sajolida)
  • QA Check deleted (Info Needed)

#9 Updated by alant over 5 years ago

This is actually a good step towards replacing this our OpenPGP systray icon (it's actually not an applet) by an actual application with a dbus interface that could be triggered e.g. by a gnome-shelle addon. This will anyway be necessary if we drop gnome-panel for tails jessie.

#10 Updated by BitingBird about 5 years ago

  • Affected tool set to OpenPGP Applet

#11 Updated by nodens over 3 years ago

  • Blocks deleted (Feature #7435: Add Tails OpenPGP Applet to the Applications menu)

#12 Updated by nodens about 2 years ago

  • Status changed from Confirmed to Resolved

Hi,

OpenPGP applet is moving to its new home on https://salsa.debian.org/openpgp-applet-team/openpgp-applet

This issue has been duplicated upstream: https://salsa.debian.org/openpgp-applet-team/openpgp-applet/issues/5

I'm closing this one. Feel free to comment on the upstream link!

You will need an account on Salsa. If you don't have one already, you can create one on https://signup.salsa.debian.org/.

Cheers!

#13 Updated by intrigeri about 2 years ago

  • Status changed from Resolved to Duplicate

Also available in: Atom PDF