Project

General

Profile

Feature #7419

Feature #7377: Improve Windows 8 camouflage

Rename Tor Browser in camouflage mode?

Added by anonym over 5 years ago. Updated over 1 year ago.

Status:
Rejected
Priority:
Low
Assignee:
-
Category:
Camouflage
Target version:
-
Start date:
06/19/2014
Due date:
% Done:

0%

Feature Branch:
Type of work:
Code
Blueprint:
Starter:
Yes
Affected tool:
Browser

Description

The name "Tor Browser" is pretty suspicious, and can be seen in the title bar (BTW, in Windows 8 there's no text in the title bar) and the button right of the URL box. We may want to change it to "Internet Explorer 11", or maybe just "IE11". Code for this is already present in config/chroot_local-includes/usr/local/sbin/unsafe-browser's set_chroot_browser_name, which we could put in a separated script so the code can be shared.

The question is if it's too small a detail to be bothered about, since other imperfections our camouflage script has probably are at least as noticeable as this one is.


Related issues

Related to Tails - Feature #7383: Find an XUL expert to improve browser camouflage Rejected 06/10/2014
Blocked by Tails - Bug #7951: Refactor code for task-specific browsers Resolved 09/26/2014

History

#1 Updated by u almost 5 years ago

  • Priority changed from Normal to Low
  • Type of work changed from Discuss to Code

#2 Updated by intrigeri almost 5 years ago

  • Blocked by Bug #7951: Refactor code for task-specific browsers added

#3 Updated by intrigeri almost 5 years ago

  • Starter changed from No to Yes

Once #7951 is merged, the code to change a browser's name will be in the set_chroot_browser_name function, in config/chroot_local-includes/usr/local/lib/tails-shell-library/chroot-browser.sh. One can play with it live in Tails by modifying /usr/local/bin/tor-browser.

#4 Updated by BitingBird almost 5 years ago

  • Affected tool set to Browser

#5 Updated by BitingBird almost 5 years ago

  • Related to Feature #7383: Find an XUL expert to improve browser camouflage added

#6 Updated by intrigeri over 1 year ago

  • Status changed from Confirmed to Rejected

We dropped camouflage mode a while ago.

Also available in: Atom PDF