Project

General

Profile

Bug #7406

Feature #7377: Improve Windows 8 camouflage

OpenPGP Applet system tray icon should be themable

Added by alant over 5 years ago. Updated over 2 years ago.

Status:
Rejected
Priority:
Low
Assignee:
-
Category:
Camouflage
Target version:
-
Start date:
06/12/2014
Due date:
% Done:

0%

Feature Branch:
Type of work:
Code
Blueprint:
Starter:
Affected tool:
OpenPGP Applet

Description

make_icon_source should use something like g_themed_icon_new_from_names, e.g. so that Tails' Windows Camouflage mode can set different icons without resorting to ugly hacks.


Related issues

Related to Tails - Bug #7742: Non-DFSG compliant images in the Tails OpenPGP Applet Resolved 08/04/2014

History

#1 Updated by intrigeri over 5 years ago

Subject: OpenPGP Applet system tray icon should be themable

#2 Updated by intrigeri over 5 years ago

  • Subject changed from gpgApplet should ues a themable systray icon to OpenPGP Applet system tray icon should be themable
  • Status changed from New to Confirmed

#3 Updated by intrigeri over 5 years ago

  • Description updated (diff)

#4 Updated by alant over 5 years ago

OpenPGP applet lives in the tails repository at http://git.tails.boum.org/tails/. Most code is in config/chroot_local-includes/usr/local/bin/gpgApplet. One can hack live on /usr/local/bin/gpgApplet and pkill -f gpgAplet then gpgApplet.

#5 Updated by nodens about 5 years ago

The code currently lives at https://git-tails.immerda.ch/nodens/openpgp-applet/. Work should be done in the master branch first. Updating the upstream metadata (dependencies in Makefile.PL, etc.) would be appreciated. Testing on Wheezy and current Debian unstable is important.

#6 Updated by nodens about 5 years ago

  • Related to Feature #6507: Package our OpenPGP applet for Debian and maintain it there added

#7 Updated by nodens about 5 years ago

  • Related to Bug #7742: Non-DFSG compliant images in the Tails OpenPGP Applet added

#8 Updated by nodens about 5 years ago

  • Related to deleted (Feature #6507: Package our OpenPGP applet for Debian and maintain it there)

#9 Updated by nodens almost 5 years ago

Hi, a few thoughts about this.

Since icons for Tails OpenPGP Applet live in /usr/share/perl5/auto/share/dist/OpenPGP_Applet/ now since File::ShareDir is used (at least in my repo), it's not that easy to make them themables. I'm reluctant to go back to /usr/share paths only since it makes things more difficult for distribution as a standalone project.

What could probably be done is modifying the icon search code to check for icons in the proper theme path before falling back to the embedded ones. The packaging (debian or otherwise) can move the icons to the proper /usr/share path.

#10 Updated by nodens almost 5 years ago

  • Related to Feature #6507: Package our OpenPGP applet for Debian and maintain it there added

#11 Updated by intrigeri almost 5 years ago

What could probably be done is modifying the icon search code to check for icons in the proper theme path before falling back to the embedded ones.

ACK.

#12 Updated by BitingBird almost 5 years ago

  • Affected tool set to OpenPGP Applet

#13 Updated by BitingBird almost 5 years ago

  • Category set to Camouflage

#14 Updated by nodens about 4 years ago

  • Related to deleted (Feature #6507: Package our OpenPGP applet for Debian and maintain it there)

#15 Updated by u over 2 years ago

  • Priority changed from Normal to Low
  • Starter deleted (Yes)

I'm setting this low priority as the cost benefit ratio seems very low from my POV.

#16 Updated by intrigeri over 2 years ago

  • Status changed from Confirmed to Rejected

Rejecting as we have no Camouflage mode anymore.

Also available in: Atom PDF