Project

General

Profile

Bug #7395

Feature #6015: Tails based on Wheezy

Feature #6342: Update Windows camouflage for GNOME3

Bug #7329: Adapt the Unsafe Browser for the Windows 8 camouflage

New visual indicator for Unsafe Browser in Windows 8 camouflage?

Added by anonym over 5 years ago. Updated over 5 years ago.

Status:
Rejected
Priority:
Elevated
Assignee:
-
Category:
Camouflage
Target version:
Start date:
06/11/2014
Due date:
% Done:

100%

Feature Branch:
Type of work:
Discuss
Blueprint:
Starter:
Yes
Affected tool:

Description

In the Unsafe Browser's design document we have:

Set the default navigation bar search engine to English Wikipedia.
This will serve as a visual indicator that the Unsafe Browser is
being used, which will be especially useful when Windows camouflage
is activated since the scary colored theme is disabled.

However, the Iceweasel theme we apply in the Windows 8 camouflage, which we also apply to the Unsafe Browser then, has no search bar, because there's no such thing in Internet Explorer 10. I say we simply drop this part of the design.

The question is what kind of "visual indicator" we can replace it with, if any. How important do we think this has been for our users so far? Can we just drop it all together?

History

#1 Updated by intrigeri over 5 years ago

Just to be clear: if we don't re-add another indicator, then there's nothing at all that allows one to distinguish an Unsafe Browser window from a Tor Browser window? If this is so, then I think this clearly conflicts with the "make it hard to shoot yourself in the foot" goal of Tails.

Given the intended usecase of the Unsafe Browser, and given there are Wi-Fi hotspots that require one to re-authenticate every 30 minutes or so, it's almost sure that some users keep this window open in such situations (and are we to blame them).

#2 Updated by anonym over 5 years ago

  • Category changed from 183 to Camouflage

#3 Updated by intrigeri over 5 years ago

  • Subject changed from New "visual indicator" for Unsafe Browser in Windows 8 camouflage? to New visual indicator for Unsafe Browser in Windows 8 camouflage?
  • Status changed from New to Confirmed
  • Assignee set to anonym

#4 Updated by anonym over 5 years ago

  • Status changed from Confirmed to New
  • Assignee changed from anonym to intrigeri
  • QA Check set to Info Needed

intrigeri wrote:

Just to be clear: if we don't re-add another indicator, then there's nothing at all that allows one to distinguish an Unsafe Browser window from a Tor Browser window?

I hadn't noticed/thought about this before, but the title and button left of the URL box differ between the two browsers:

  • in the Tor Browser both say "Tor Browser", and
  • in the Unsafe Browser both say "Unsafe Browser".

IMHO that's a better visual indicator than the obscure default choice of search engine, so I'd like to reject this bug, and then proceed with removing the code in the Unsafe Browser script that deals with the search engine bar.

Sounds ok?

#5 Updated by intrigeri over 5 years ago

  • Status changed from New to Rejected
  • Assignee deleted (intrigeri)
  • Starter changed from No to Yes

anonym wrote:

IMHO that's a better visual indicator than the obscure default choice of search engine,

Fully agreed.

so I'd like to reject this bug,

Done.

and then proceed with removing the code in the Unsafe Browser script that deals with the search engine bar.

Awesome. I'm assuming this is implicitly tracked by the comments on #7329, so not filing a dedicated ticket right away.

#6 Updated by intrigeri over 5 years ago

  • % Done changed from 0 to 100
  • QA Check deleted (Info Needed)

Also available in: Atom PDF