Project

General

Profile

Feature #7394

Bug #7423: Have what we need included in Debian Jessie

Feature #7311: Investigate using GNOME Shell for Jessie

Evaluate xserver-xorg-video-modesetting for KMS support in QEMU and others

Added by intrigeri almost 6 years ago. Updated over 5 years ago.

Status:
Resolved
Priority:
High
Assignee:
-
Category:
Virtualization
Target version:
-
Start date:
06/11/2014
Due date:
% Done:

0%

Feature Branch:
feature/kms-for-cirrus-etc
Type of work:
Research
Blueprint:
Starter:
No
Affected tool:

Description

It would be good to support KMS for more video adapters in Tails, especially to allow migrating to GNOME Classic in Jessie (#7311), and to make our upcoming custom Plymouth theme (#5948) work on a broader range of hardware. This would also generally improve the user story we provide to people who use Tails in virtual machines, e.g. with the QEMU (virtual) Cirrus video adapter.


Related issues

Related to Tails - Feature #5948: Custom plymouth theme Confirmed
Related to Tails - Feature #7564: Try GNOME Shell in Jessie or sid with llvmpipe in libvirt/qemu Resolved 07/11/2014
Duplicated by Tails - Bug #7565: Try gnome-shell in Jessie or sid VM with cirrus KMS Duplicate 07/11/2014

History

#1 Updated by intrigeri almost 6 years ago

  • Related to Feature #7311: Investigate using GNOME Shell for Jessie added

#2 Updated by intrigeri almost 6 years ago

#3 Updated by intrigeri almost 6 years ago

  • Target version set to Tails_2.0

#4 Updated by intrigeri almost 6 years ago

  • Target version deleted (Tails_2.0)
  • Parent task set to #7423

#5 Updated by intrigeri almost 6 years ago

  • Priority changed from Normal to High

Setting priority to the same value as other pre-Jessie-freeze tasks.

#6 Updated by intrigeri almost 6 years ago

  • Related to deleted (Feature #7311: Investigate using GNOME Shell for Jessie)

#7 Updated by intrigeri almost 6 years ago

  • Related to Feature #7311: Investigate using GNOME Shell for Jessie added

#8 Updated by intrigeri over 5 years ago

  • Related to deleted (Feature #7311: Investigate using GNOME Shell for Jessie)

#9 Updated by intrigeri over 5 years ago

  • Parent task changed from #7423 to #7411

#10 Updated by intrigeri over 5 years ago

  • Duplicated by Bug #7565: Try gnome-shell in Jessie or sid VM with cirrus KMS added

#11 Updated by intrigeri over 5 years ago

  • Parent task changed from #7411 to #7311

#12 Updated by intrigeri over 5 years ago

  • Related to Feature #7564: Try GNOME Shell in Jessie or sid with llvmpipe in libvirt/qemu added

#13 Updated by alant over 5 years ago

GNOME shell starts on default sid with libvirt qemu/kvm with spice/cirrus but it doesn't use the KMS driver even though cirrusdrmfb (fb0) is primary device. glxinfo | grep renderer still outputs Gallium 0.4 on llvmpipe (LLVM 3.4, 128 bits).

#14 Updated by alant over 5 years ago

Please note xserver-xorg-video-modesetting is installed.

$ dpkg -l xserver-xorg-video-modesetting
Desired=Unknown/Install/Remove/Purge/Hold
| Status=Not/Inst/Conf-files/Unpacked/halF-conf/Half-inst/trig-aWait/Trig-pend
|/ Err?=(none)/Reinst-required (Status,Err: uppercase=bad)
||/ Name                   Version          Architecture     Description
+++-======================-================-================-==================================================
ii  xserver-xorg-video-mod 0.9.0-1          amd64            X.Org X server -- Generic modesetting driver

#15 Updated by alant over 5 years ago

I get the same results in fedora 20 live VM with cirrus graphics on a debian sid qemu/kvm host: cirrus kvs kernel module is used, modesetting xorg video driver is used, but glxinfo still outputs llvmpipe as 3D accelerator.

#16 Updated by intrigeri over 5 years ago

alant wrote:

I get the same results in fedora 20 live VM with cirrus graphics on a debian sid qemu/kvm host: cirrus kvs kernel module is used, modesetting xorg video driver is used, but glxinfo still outputs llvmpipe as 3D accelerator.

OK, then it might be expected that llvmpipe is still used. And the remaining questions are:

  • is it fast enough?
  • are things worse, or better, if the modesetting xorg driver is not available?

#17 Updated by intrigeri over 5 years ago

  • Assignee changed from intrigeri to alant
  • QA Check set to Info Needed

alant wrote:

GNOME shell starts on default sid with libvirt qemu/kvm with spice/cirrus but it doesn't use the KMS driver even though cirrusdrmfb (fb0) is primary device.

I can't reproduce that on current sid: the journal tells me that the modesetting X.Org video driver is used, in preference to the cirrus one. In any case, on my system, the resulting VM is fast enough.

Alan, can you still reproduce the "doesn't use the KMS driver" part in your environment?

glxinfo | grep renderer still outputs Gallium 0.4 on llvmpipe (LLVM 3.4, 128 bits).

Same here (except s/128/256).

Also, note that the same sid VM, with a Cirrus virtual video adapter, and without the modesetting driver, also supports GNOME Shell. However, I see many ugly display artifacts that I can't see with the modesetting driver, which tends to confirm IMO that we should indeed ship the modesetting driver. Additionally, task-desktop Depends xserver-xorg-video-all, which itself Depends xserver-xorg-video-modesetting, so I see no reason to diverge from Debian in this respect.

Hence, I'm going to ensure we install the modesetting driver on feature/jessie.

#18 Updated by intrigeri over 5 years ago

  • Status changed from Confirmed to Resolved
  • Assignee deleted (alant)
  • QA Check deleted (Info Needed)

intrigeri wrote:

Hence, I'm going to ensure we install the modesetting driver on feature/jessie.

It's already the case, as we pull xserver-xorg-video-all.

#19 Updated by sajolida over 5 years ago

  • Category changed from Hardware support to Virtualization

Also available in: Atom PDF