Project

General

Profile

Bug #7393

Feature #7377: Improve Windows 8 camouflage

Icons are initially smaller than they should in window-picker-applet

Added by anonym over 5 years ago. Updated over 4 years ago.

Status:
Rejected
Priority:
Low
Assignee:
-
Category:
Camouflage
Target version:
-
Start date:
06/11/2014
Due date:
% Done:

0%

Feature Branch:
Type of work:
Code
Blueprint:
Starter:
No
Affected tool:

Description

When an icon is displayed in window-picker-applet for the first time (e.g. when starting an application) it's at ~75% of its size, and expands to the full 100% only after a new icon is displayed in it (e.g. after starting another application).

History

#1 Updated by intrigeri over 5 years ago

I suspect that Alan won't want to see it as a blocker for 1.1, as patching window-picker-applet is likely needed to fix this bug.

#2 Updated by anonym over 5 years ago

Some more info on this which may be relevant for debugging:

  • For panel heights >= 30, the initial icon size is always the same, around 30x30 (verified by taking a screen shot and comparing it pixel by pixel).
  • If I set the panel height to <= 30 pixels, then all icons are opened at full size (also verified by screen shot comparision).
  • Another way to force a "small" icon to change to its correct full sizeis to change the panel's height by two steps. One step is not enough. Yet another way is to drag the icon in the list. Not sure if any of this is of much value.
  • In the sources, src/task-item.c there's: #define DEFAULT_TASK_ITEM_HEIGHT 26. That's pretty close to the "30x30" initial size I've seen, but still not exact, so perhaps it's not the cause of the issue.

#3 Updated by anonym over 5 years ago

  • Assignee changed from alant to anonym

intrigeri wrote:

I suspect that Alan won't want to see it as a blocker for 1.1, as patching window-picker-applet is likely needed to fix this bug.

You beat me to it, see https://mailman.boum.org/pipermail/tails-dev/2014-June/006091.html

Perhaps I should have assigned it to myself then, if since alant isn't very excited at looking at C code.

#4 Updated by anonym over 5 years ago

  • Category set to Camouflage

#5 Updated by intrigeri over 5 years ago

  • Status changed from New to Confirmed

(As said on the ML, IMO the first step is to report that bug upstream, unless we're 100% positive that we'll be able to have a fix ready very soon... which I somewhat doubt :)

#6 Updated by anonym over 5 years ago

  • Status changed from Confirmed to New

#7 Updated by anonym over 5 years ago

  • Status changed from New to Confirmed

#8 Updated by anonym over 5 years ago

  • Target version deleted (Tails_1.1)
  • Parent task deleted (#6342)

I doubt we can expect this to be done for 1.1. Dropping the milestone and re-parenting the ticket to "phase two".

#9 Updated by anonym over 5 years ago

  • Parent task set to #7377

#10 Updated by alant almost 5 years ago

  • Status changed from Confirmed to Rejected
  • Assignee deleted (anonym)

Closing all wheezy-specific camouflage tasks.

#11 Updated by BitingBird over 4 years ago

  • Priority changed from Elevated to Low

Also available in: Atom PDF