Project

General

Profile

Feature #7349

Feature #7377: Improve Windows 8 camouflage

Package window-picker-applet

Added by u over 5 years ago. Updated about 5 years ago.

Status:
Rejected
Priority:
Normal
Assignee:
Category:
-
Target version:
Start date:
05/31/2014
Due date:
% Done:

0%

Feature Branch:
Type of work:
Debian
Blueprint:
Starter:
No
Affected tool:

Description

as seen on tails-dev@

We need a package for https://github.com/lanoxx/window-picker-applet,
which was reviewed at commit ebcc436c1e

There is an old packaging at:
https://packages.debian.org/search?keywords=window-picker-applet

The current ugly but working packaging is at:
http://git.tails.boum.org/gnome-panel-applet-window-picker/

better start from http://packages.qa.debian.org/window-picker-applet


Related issues

Related to Tails - Bug #7365: Report bugs spotted by window-picker-applet audit upstream Resolved 06/03/2014
Related to Tails - Bug #8147: Install windowpicker applet from Debian Rejected 10/14/2014

History

#1 Updated by intrigeri over 5 years ago

  • Subject changed from Package gnome-window-picker-applet to Package window-picker-applet
  • Status changed from New to Confirmed

#2 Updated by intrigeri over 5 years ago

  • Target version set to Tails_1.1
  • Parent task set to #7312

#4 Updated by intrigeri over 5 years ago

There is now an ITP bug http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=750436

Great! I usertagged it "user-interface".

Don't hesitate making it clear that you're doing this because Tails
needs it, when filing such bugs: it might encourage people to give you
a hand, and/or help Debian folks who did not get it yet to understand
that we really are contributing to Debian :)

#5 Updated by alant over 5 years ago

There is work done and we decided on tails-dev that the current package could go in 1.1 as long as a good package should reach debian soon, so I wanted to make this a subtask of #7377 but for some reason redmine answers me "Parent task is invalid" when I try to do so.

#6 Updated by intrigeri over 5 years ago

  • Status changed from Confirmed to In Progress

#7 Updated by anonym over 5 years ago

  • Parent task deleted (#7312)

#8 Updated by anonym over 5 years ago

  • Parent task set to #7377

#9 Updated by intrigeri over 5 years ago

  • Related to Bug #7365: Report bugs spotted by window-picker-applet audit upstream added

#10 Updated by intrigeri over 5 years ago

  • Target version changed from Tails_1.1 to Tails_1.2

#11 Updated by intrigeri about 5 years ago

What's the status on that one?

Note that all our patches were merged upstream (#7365), so basing the package on an up-to-date Git snapshot seems to be the way to go.

#12 Updated by BitingBird about 5 years ago

I see something in sid, but no source package. Waiting for the ftp masters maybe ? https://packages.debian.org/sid/window-picker-applet

#13 Updated by intrigeri about 5 years ago

I see something in sid, but no source package. Waiting for the ftp masters maybe ?

No, it's not in sid anymore (only a non-decrufted binary package for the unofficial m68k port, no idea why it's still around). Our updated package hasn't been uploaded yet, and I don't think it's ready either.

#14 Updated by intrigeri about 5 years ago

  • Target version changed from Tails_1.2 to Tails_1.2.1

Postponing to the next release, again.

#15 Updated by u about 5 years ago

The applet has been merged into gnome-applets source tree, and will be part of next gnome-applets release.
See: https://git.gnome.org/browse/gnome-applets/commit/?id=1488a6eb2edea605

So, should this ticket be closed?

#16 Updated by intrigeri about 5 years ago

The applet has been merged into gnome-applets source tree, and will be part of next gnome-applets release.

Good news! :)

So, should this ticket be closed?

Yes, probably... once it's been verified that our bunch of bugfixes (merged into the original upstream) are part of the code that was merged into gnome-applets.

However, we'll only have this in Jessie+1, which means we'll carry our current, ugly, without bugfixes package for about 3 more years. I'm not very happy with that situation.

One way to solve this would be to 1. wait for gnome-applets to be released upstream with this applet included; 2. wait for the new upstream release to reach sid and then testing; 3. backport the newer gnome-applets for Jessie. Each "wait" steps may actually need some help from us, if we want to see it happen at all: the Debian GNOME team isn't putting much resources into the flashback mode.

So, IMO when we close this ticket, we should replace it with another one that would be about having the newer gnome-applets in jessie-backports, with the subtasks described above.

#17 Updated by u about 5 years ago

intrigeri wrote:

The applet has been merged into gnome-applets source tree, and will be part of next gnome-applets release.

Good news! :)

So, should this ticket be closed?

Yes, probably... once it's been verified that our bunch of bugfixes (merged into the original upstream) are part of the code that was merged into gnome-applets.

However, we'll only have this in Jessie+1, which means we'll carry our current, ugly, without bugfixes package for about 3 more years. I'm not very happy with that situation.

Sorry, i was a bit slow on that one..

One way to solve this would be to 1. wait for gnome-applets to be released upstream with this applet included; 2. wait for the new upstream release to reach sid and then testing; 3. backport the newer gnome-applets for Jessie. Each "wait" steps may actually need some help from us, if we want to see it happen at all: the Debian GNOME team isn't putting much resources into the flashback mode.

So, IMO when we close this ticket, we should replace it with another one that would be about having the newer gnome-applets in jessie-backports, with the subtasks described above.

I will create those tickets and assign them to me then.

#18 Updated by u about 5 years ago

  • Status changed from In Progress to Rejected

Created #8111, #8112, #8113 as a follow-up.

#19 Updated by intrigeri about 5 years ago

  • Related to Bug #8147: Install windowpicker applet from Debian added

Also available in: Atom PDF