Project

General

Profile

Bug #7334

Pressing the power button in the GNOME session does not immediately trigger emergency shutdown

Added by anonym over 5 years ago. Updated over 3 years ago.

Status:
Resolved
Priority:
Low
Assignee:
-
Category:
-
Target version:
-
Start date:
05/29/2014
Due date:
% Done:

0%

Feature Branch:
Type of work:
Code
Blueprint:
Starter:
No
Affected tool:

Description

From the 1.1~beta1 testing session:

When pressing the power button after Tails is done starting, the user is asked for shutdown/reboot/etc.
and still has to press enter to start the shutdown

Regression since 1.0.


Related issues

Related to Tails - Bug #7335: The power button does not trigger emergency shutdown in the Greeter Confirmed 05/29/2014
Related to Tails - Bug #11385: Update /doc/first_steps/shutdown to Tails 2.0 Resolved 04/28/2016

History

#1 Updated by anonym over 5 years ago

  • Subject changed from Wheezy: pressing the power button does not trigger emergency shutdown to Wheezy: pressing the power button in the GNOME session does not trigger emergency shutdown

#2 Updated by anonym over 5 years ago

  • Related to Bug #7335: The power button does not trigger emergency shutdown in the Greeter added

#3 Updated by intrigeri over 5 years ago

IMO, that's not a blocker for 1.1:

  1. it's not as if we had documented that the power button triggers an immediate power-off, have we?
  2. we provide two other ways to quickly shutdown Tails
  3. pressing Enter doesn't take substantially more time

#4 Updated by intrigeri over 5 years ago

  • Target version deleted (Tails_1.1)

9 days later, I'm dropping the 1.1 milestone.

#5 Updated by intrigeri over 5 years ago

  • Subject changed from Wheezy: pressing the power button in the GNOME session does not trigger emergency shutdown to Pressing the power button in the GNOME session does not immediately trigger emergency shutdown

#6 Updated by anonym over 5 years ago

  • Priority changed from Elevated to Normal
  • Type of work changed from Research to Discuss

intrigeri wrote:

IMO, that's not a blocker for 1.1:

  1. it's not as if we had documented that the power button triggers an immediate power-off, have we?

True. Some people have even complained about it (Jake Appelbaum IIRC). Still, some may have grown used to it.

  1. we provide two other ways to quickly shutdown Tails

Still, it's a lot faster and reliable.

  1. pressing Enter doesn't take substantially more time

Fair enough, and it should be easy to re-train to this. Downgrading priority because of this.

I propose we reject this bug.

#7 Updated by intrigeri over 5 years ago

I propose we reject this bug.

I think it would be good to have this working, so I would find it sad to just close this ticket.
IMO that's a low priority task: patches welcome, but we don't intend to work on it ourselves.
Ideally, one would patch a GSettings thing in GNOME, to dictate in a more fine-grained way what the power button does.
If GNOME people agree, then that would be a good thing to add to their upcoming privacy/security bounty program.
Else, well, we won't maintain in-house patches for that, so then yes, we should reject this ticket.

#8 Updated by BitingBird over 5 years ago

  • Priority changed from Normal to Low

#9 Updated by intrigeri over 5 years ago

  • Type of work changed from Discuss to Code

#10 Updated by sycamoreone over 3 years ago

I think this was magically fixed by the switch to Jessie in Tails 2.0. At least for me, pressing the power button triggers an emergency shutdown since that release.

#11 Updated by elouann over 3 years ago

  • Assignee set to sycamoreone

sycamoreone wrote:

I think this was magically fixed by the switch to Jessie in Tails 2.0. At least for me, pressing the power button triggers an emergency shutdown since that release.

I think there was another issue. Could you please test if it's still working after suspending/locking the screen?

#12 Updated by sycamoreone over 3 years ago

I just tried the power button after a number of suspends and the emergency shutdown was triggered immediately.

#13 Updated by sycamoreone over 3 years ago

Checked a few more cases: The power button works fine after unlocking the screen locker, but not while the screen is locked.

I suggest that the interaction with the screen locker should not be tracked here but in #5684. It also seems to be resolved already in #6017 for the new screen locker.

#14 Updated by intrigeri over 3 years ago

  • Status changed from Confirmed to Resolved
  • Assignee deleted (sycamoreone)

sycamoreone wrote:

Checked a few more cases: The power button works fine after unlocking the screen locker, but not while the screen is locked.

I suggest that the interaction with the screen locker should not be tracked here but in #5684. It also seems to be resolved already in #6017 for the new screen locker.

Re-opened #6017 (there is no "new screen locker" AFAIK, so your tests invalidate what was reported on #6017 previously), which tracks the only remaining known issue => closing this one.

elouann, please file a different ticket if you still notice other problems with the power button :)

#15 Updated by sajolida about 3 years ago

  • Related to Bug #11385: Update /doc/first_steps/shutdown to Tails 2.0 added

Also available in: Atom PDF