Project

General

Profile

Bug #7333

Wheezy: device removal before Greeter login does not trigger emergency shutdown

Added by anonym over 5 years ago. Updated over 5 years ago.

Status:
Resolved
Priority:
Elevated
Assignee:
-
Category:
-
Target version:
Start date:
05/29/2014
Due date:
% Done:

100%

Feature Branch:
bugfix/7333-emergency-shutdown-before-login
Type of work:
Research
Blueprint:
Starter:
No
Affected tool:

Description

From the 1.1~beta1 test session:

When removing Tails USB during Greeter, the emergency shutdown is not triggered, I got a black screen
with "amnesia login:" while removing the same device when Tails is fully started effectively launch
the emergency shutdown

I tested on real hardware and got tons of SQUASHFS errors and no shutdown at all. I confirmed that memlockd and the udev watchdog were running at the time.

Regression since 1.0.

Associated revisions

Revision 31330d02 (diff)
Added by Tails developers over 5 years ago

Make sure /etc/default/locale exists, with a sensible default value (Closes: #7333).

Before Tails Greeter's PostLogin script our run, /etc/default/locale does not
exist on Wheezy. Our tails-kexec initscript (and quite a few other scripts we
run) depends on this file to exist. So, let's make sure it exists, with
a sensible default value.

History

#1 Updated by intrigeri over 5 years ago

  • Assignee set to intrigeri

I'll take it. It seems that touch /etc/default/locale is enough to make /etc/init.d/tails-kexec work again.

#2 Updated by intrigeri over 5 years ago

  • Feature Branch set to bugfix/7333-emergency-shutdown-before-login

#3 Updated by intrigeri over 5 years ago

  • Status changed from Confirmed to In Progress
  • Assignee changed from intrigeri to anonym
  • % Done changed from 0 to 50
  • QA Check set to Ready for QA

#4 Updated by anonym over 5 years ago

  • Status changed from In Progress to 11
  • Assignee deleted (anonym)
  • % Done changed from 50 to 100
  • QA Check changed from Ready for QA to Pass

#5 Updated by BitingBird over 5 years ago

  • Status changed from 11 to Resolved

Also available in: Atom PDF