Project

General

Profile

Bug #7326

Feature #6015: Tails based on Wheezy

Feature #6342: Update Windows camouflage for GNOME3

Fix systray icons in Windows 8 camouflage

Added by anonym over 4 years ago. Updated over 4 years ago.

Status:
Resolved
Priority:
Normal
Assignee:
-
Category:
Camouflage
Target version:
Start date:
05/28/2014
Due date:
% Done:

100%

QA Check:
Pass
Feature Branch:
bugfix/7326-systray-icons
Type of work:
Code
Blueprint:
Starter:
No
Affected tool:

Description

None of the icons used in the systray looks like something from windows (ignoring the size, see #7316), and many of them contrast sharply against the blue theme.

The systray icons should be changed to ones from Windows that makes sense, either esthetically (e.g. Florence could have the keyboard icon which I think correspond to keyboard layout settings, not an on screen keyboard) or functionally (e.g. nm-applet could have Windows' networking applet's icon).

History

#1 Updated by alant over 4 years ago

  • % Done changed from 0 to 10

There seems not to be a concept of systrey icon theme. Systray icons are provided by applications.

Here are some of them:

- gpgApplet: /usr/share/pixmaps/gpgApplet/scalable/gpgApplet-*.svg
- florence: /usr/share/pixmaps/florence.png
- volume: theme:audio-volume-*-symbolic
- notifications: theme:mail-message-new (this one might be problematic as it's also used in other applications and places)

#2 Updated by intrigeri over 4 years ago

  • Status changed from Confirmed to In Progress

#3 Updated by alant over 4 years ago

pidgin: /usr/share/pixmaps/pidgin/tray/. It looks like these icons should be changeable in ~/.local/share/pixmaps/pidgin/tray/ when seeing strace output, but that doesn't work.

#4 Updated by alant over 4 years ago

  • % Done changed from 10 to 30
  • Feature Branch set to bugfix/7326-systray-icons

gpgApplet, florence, volume and notifications tray icons should be fixed in tails:bugfix/7326-systray-icons and gnome-theme-windows8:bugfix/7326-systray-icons. These changes should now be tested. Note that one should currently execute /usr/local/sbin/tails-win8-theme-adapt-icons as root manually.

#5 Updated by alant over 4 years ago

  • % Done changed from 30 to 40

Test results:

- gpgApplet icon is wrong at startup. It seems to use the 48x48 icon at startup and the scalable version when the clipboard content is updated;
- volume icon is not updated unless the volume is changed. It seems that we should either change the volume or set the icon theme before the session starts;
- network-manager, notifications and florence icons are correct.

#6 Updated by alant over 4 years ago

  • % Done changed from 40 to 50

- gpgApplet icon is wrong at startup. It seems to use the 48x48 icon at startup and the scalable version when the clipboard content is updated;
- volume icon is not updated unless the volume is changed. It seems that we should either change the volume or set the icon theme before the session starts;

These issues should now be fixed.

#7 Updated by alant over 4 years ago

  • Assignee changed from alant to anonym
  • % Done changed from 50 to 60
  • QA Check changed from Dev Needed to Ready for QA

These issues should now be fixed.

Tested OK.

#8 Updated by anonym over 4 years ago

  • Category set to Camouflage

#9 Updated by anonym over 4 years ago

  • Status changed from In Progress to Fix committed
  • Assignee deleted (anonym)
  • % Done changed from 60 to 100
  • QA Check changed from Ready for QA to Pass

#10 Updated by BitingBird over 4 years ago

  • Status changed from Fix committed to Resolved

Also available in: Atom PDF