Project

General

Profile

Bug #7283

Feature #5479: Bridge support

Feature #6839: Tor bridges support: complete phase two

Feature #6840: Upstream our Tor Launcher changes

Use upstream solution for Tor Launcher: Set ClientTransportPlugin according to the bridge entries

Added by anonym over 5 years ago. Updated over 4 years ago.

Status:
Resolved
Priority:
Normal
Assignee:
-
Category:
Tor configuration
Target version:
Start date:
05/26/2014
Due date:
% Done:

100%

Feature Branch:
feature/8925-tor-0.2.6
Type of work:
Code
Blueprint:
Starter:
No
Affected tool:
Tor Launcher

Description

Commit 75f76d4 in our Tor Launcher Git repo is part of our delta against upstream.

Upstream has chosen a different approach than us: https://trac.torproject.org/projects/tor/ticket/11512

We should wait until this have been implemented by upstream, but if it takes too long we may consider writing a patch.


Related issues

Related to Tails - Feature #7087: Do not bundle Tor Launcher in the main Tails Git repository Resolved 04/15/2014
Blocked by Tails - Feature #7934: Upgrade to Tor 0.2.6.x Resolved 09/22/2014

Associated revisions

Revision 3710b2c9 (diff)
Added by Tails developers over 4 years ago

Remove our in-tree version of Tor Launcher and use the Tor Browser's instead.

Since Tor 0.2.6.x our custom patches for the ClientTransportPlugin
hacks are not needed any more. Now we can set ClientTransportPlugin
for the relevant transports in torrc without it causing problems with
any of the various *Proxy options. So let's do that!

Will-fix: #7283

Revision e88f3b27
Added by intrigeri over 4 years ago

Merge remote-tracking branch 'origin/feature/8925-tor-0.2.6' into devel

Fix-committed: #7934, #9114, #7620, #7087, #7283, #6840

History

#1 Updated by anonym over 5 years ago

Bad news, see upstream bug.

They decided to go with backporting a Tor 0.2.6.x feature (current implementation of Tor ticket #8402) into the Tor 0.2.4.22 they ship in TBB 3.6.2. I doubt moving the delta from Tor Launcher to Tor is a wise decision for us, maintenance wise, so we may have to live with our current Tor Launcher delta until Tor 0.2.6.x goes stable.

#2 Updated by intrigeri over 5 years ago

They decided to go with backporting a Tor 0.2.6.x feature (current implementation of
Tor ticket #8402) into the Tor
0.2.4.22 they ship in TBB 3.6.2.

Wow. I'd be surprised that something that TBB will ship anyway could not be sneaked into 0.2.5. I suggest asking Nick about it, if the TBB team hasn't already tried.

I doubt moving the delta from Tor Launcher to Tor is a wise decision for us, maintenance wise, so we may have to live with our current Tor Launcher delta until Tor 0.2.6.x goes stable.

That's acceptable, since it gives us a good enough warranty that we can drop the delta at some point.

#3 Updated by intrigeri about 5 years ago

#4 Updated by BitingBird almost 5 years ago

  • Affected tool set to Tor Launcher

#5 Updated by intrigeri almost 5 years ago

  • Subject changed from Tor Launcher: Set ClientTransportPlugin according to the bridge entries to Use upstream solution for Tor Launcher: Set ClientTransportPlugin according to the bridge entries
  • Type of work changed from Wait to Code

(The fact this ticket is blocked by Tor 0.2.6 is already expressed by a ticket relationship.)

#6 Updated by Tails over 4 years ago

  • Status changed from Confirmed to In Progress

Applied in changeset commit:30f8c35fdf2d38c0065d7ccc4f5707de7fa17504.

#7 Updated by anonym over 4 years ago

  • Target version changed from Hole in the Roof to Tails_1.3.2
  • % Done changed from 0 to 50
  • Feature Branch set to feature/8925-tor-0.2.6

#8 Updated by intrigeri over 4 years ago

  • Target version changed from Tails_1.3.2 to Tails_1.4

I doubt that we'll want to upgrade to Tor 0.2.6 in a point-release => postponing to Tails 1.4.

#9 Updated by intrigeri over 4 years ago

  • Related to Feature #7087: Do not bundle Tor Launcher in the main Tails Git repository added

#10 Updated by Tails over 4 years ago

#11 Updated by anonym over 4 years ago

  • Assignee deleted (anonym)
  • QA Check set to Ready for QA

#12 Updated by intrigeri over 4 years ago

  • Status changed from In Progress to 11
  • % Done changed from 50 to 100

#13 Updated by BitingBird over 4 years ago

  • QA Check changed from Ready for QA to Pass

#14 Updated by BitingBird over 4 years ago

  • Status changed from 11 to Resolved

Also available in: Atom PDF