Project

General

Profile

Bug #7249

Truncated notifications

Added by sajolida over 5 years ago. Updated over 4 years ago.

Status:
Resolved
Priority:
Normal
Assignee:
-
Category:
-
Target version:
Start date:
06/18/2015
Due date:
% Done:

100%

Feature Branch:
bugfix/7249-truncated-notifications
Type of work:
Code
Blueprint:
Starter:
No
Affected tool:

Description

In Tails 1.1, the desktop notifications appear truncated on the right.

I can reproduce that both on bare metal and in VirtualBox, using
different build, and resolutions.

This looks like https://bugs.mageia.org/show_bug.cgi?id=7297.

truncated-one.png View (18.6 KB) sajolida, 05/14/2014 07:26 AM

truncated-two.png View (17.1 KB) sajolida, 05/14/2014 07:27 AM


Subtasks

Bug #9610: Update doc to untruncated notificationsResolved


Related issues

Related to Tails - Feature #7259: Update screenshots on /doc/get/verify_the_iso_image_using_gnome Resolved 05/18/2014
Related to Tails - Bug #10559: MAC spoofing failure notification should point to the corresponding documentation Confirmed 01/23/2019
Duplicated by Tails - Bug #9510: pop-up notification are off-screen on some resolutions Duplicate 05/31/2015
Blocked by Tails - Feature #7557: Decide which flavour of GNOME Shell we want to use in Tails Jessie Resolved 07/11/2014 12/17/2014

Associated revisions

Revision d0782c57
Added by anonym over 4 years ago

Merge remote-tracking branch 'origin/bugfix/7249-truncated-notifications' into stable

Fix-committed: #7249

History

#1 Updated by sajolida over 5 years ago

See screenshots in attachment.

#2 Updated by intrigeri over 5 years ago

Reproduced on libvirt/SPICE. I'm astonished that neither I, nor anonym (when updating the test suite) did notice it earlier.

#3 Updated by intrigeri over 5 years ago

  • Priority changed from Normal to Elevated

#4 Updated by sajolida over 5 years ago

Several people could reproduce that with Wheezy outside of Tails. That's probably a bug of the fallback mode...

#5 Updated by sajolida over 5 years ago

  • Related to Feature #7259: Update screenshots on /doc/get/verify_the_iso_image_using_gnome added

#6 Updated by intrigeri over 5 years ago

This seems to be the same as https://bugzilla.redhat.com/show_bug.cgi?id=875214. Yes, yet another bug of the fallback mode. That's what one gets for shipping software that's almost entirely deprecated and unmaintained...

I've not been able to find an easy workaround, nor other good bug reports about this online. I have my doubts that we'll manage to fix this in time for 1.1. Regardless, I'll try to reproduce on Debian Wheezy and sid, and will definitely report this bug upstream. That's the least we can do.

#7 Updated by intrigeri over 5 years ago

Reproduced on Wheezy and sid:

On sid, it gets worse, as notification-daemon simply crashes:

I've added some more information, including a gdb backtrace, on the relevant bugs. I don't see this fixed in time for Tails 1.1 without someone diving into notification-daemon's code source (and possibly, GTK's one) => asking for help around.

#8 Updated by intrigeri over 5 years ago

Nobody I asked can help. Added more information to the upstream bug report. I'm less and less confident we can fix that in time for 1.1.

#9 Updated by BitingBird over 5 years ago

  • Type of work changed from Code to Upstream

#10 Updated by intrigeri over 5 years ago

  • Target version changed from Tails_1.1 to Tails_1.1.1

Postponing. If this isn't fixed in 1.2, I say it may become a Hole in the Roof, depending on what desktop environment we ship in Tails/Jessie and the timeline thereof.

#11 Updated by intrigeri over 5 years ago

  • Target version changed from Tails_1.1.1 to Tails_1.2

No progress, upstream bug, postponing.

#12 Updated by intrigeri about 5 years ago

  • Target version deleted (Tails_1.2)
  • Type of work changed from Upstream to Wait

I don't think there's much we can do about it. The great news is that it'll be fixed in Jessie, once we ship some flavour of GNOME Shell.

#13 Updated by intrigeri about 5 years ago

  • Blocked by Feature #7557: Decide which flavour of GNOME Shell we want to use in Tails Jessie added

#14 Updated by intrigeri about 5 years ago

Proposed NMU with patch attached on the Debian BTS.

#15 Updated by intrigeri about 5 years ago

Fixed in sid with notification-daemon (0.7.6-2).

#16 Updated by BitingBird almost 5 years ago

#17 Updated by intrigeri over 4 years ago

  • Duplicated by Bug #9510: pop-up notification are off-screen on some resolutions added

#18 Updated by intrigeri over 4 years ago

  • Assignee set to intrigeri
  • Target version set to Tails_1.4.1
  • % Done changed from 0 to 10
  • Feature Branch set to bugfix/7249-truncated-notifications
  • Type of work changed from Wait to Code

Actually, this might be trivially fixed by backporting notification-daemon from Jessie to Wheezy. Not sure it's worth my time, but oh well, let's give it a try.

#19 Updated by intrigeri over 4 years ago

  • Assignee changed from intrigeri to goupille
  • % Done changed from 10 to 20
  • QA Check set to Info Needed

The next nightly build ISO from the experimental branch (should be ready in ~30 minutes) will have a tentative fix (notification-daemon backported from Jessie): http://nightly.tails.boum.org/build_Tails_ISO_experimental/. At least it fixes the positioning for me (notifications are not cut out of the screen), but still some text is truncated at the bottom when it doesn't fit. Please test and tell me if you think that's an improvement.

Thanks for digging this old bug that I had actually tried fixing in Debian proper, and then forgot about Tails!

#20 Updated by kytv over 4 years ago

Could we be lucky enough that this fixes #8686?

#21 Updated by kytv over 4 years ago

kytv wrote:

Could we be lucky enough that this fixes #8686?

No, we're not. It's still aborting in the experimental branch but it improves things IMHO for this bug. Notifications with a lot of text will be cut off at the bottom, but most cases will see an improvement.

#22 Updated by intrigeri over 4 years ago

goupille: ping regarding #7249#note-19 -- I'd like to see this fixed in time for 1.4.1, and time is getting short :)

#23 Updated by goupille over 4 years ago

sorry, I just took a look at it...
it is more pretty with none truncated pop up but it is kind of sad that a part of message is still unreadable (I saw it at least on the synchronizing clock pop up)... I'd say it is better but it is not totally fixed

#24 Updated by intrigeri over 4 years ago

  • Assignee changed from goupille to anonym
  • QA Check changed from Info Needed to Ready for QA

it is more pretty with none truncated pop up but it is kind of sad that a part of message is still unreadable (I saw it at least on the synchronizing clock pop up)... I'd say it is better but it is not totally fixed

Thanks! That's the best we can hope for in Tails/Wheezy without working on notification-daemon ourselves (and nobody has done that in 1+ year so I don't see it happen in the close future), and it'll disappear in Tails/Jessie anyway => if it's best this way, then it's good enough for me.

#25 Updated by anonym over 4 years ago

Since most people think this half-solution is some ind of improvement (I'm personally more neutral, I must say) I'll merge this.

#26 Updated by anonym over 4 years ago

  • Status changed from Confirmed to 11
  • % Done changed from 20 to 100

#27 Updated by anonym over 4 years ago

  • Assignee deleted (anonym)

#28 Updated by anonym over 4 years ago

  • QA Check changed from Ready for QA to Pass

#29 Updated by sajolida over 4 years ago

I'm ok to ship this even if the notifications are half-truncated still. But maybe we shouldn't mark this as Resolved even after 1.4, then...

#30 Updated by intrigeri over 4 years ago

#31 Updated by intrigeri over 4 years ago

  • Status changed from 11 to Resolved
  • Target version changed from Tails_1.4.1 to Tails_2.0

So, Tails 1.4.1 has improvements in this area, and Tails 2.0 (Jessie) will fully fix it.

#32 Updated by intrigeri about 4 years ago

  • Related to Bug #10559: MAC spoofing failure notification should point to the corresponding documentation added

Also available in: Atom PDF