Project

General

Profile

Bug #7232

Boot in older VirtualBox is broken by syslinux 6

Added by intrigeri over 5 years ago. Updated about 5 years ago.

Status:
Resolved
Priority:
Normal
Assignee:
-
Category:
Virtualization
Target version:
Start date:
05/08/2014
Due date:
% Done:

100%

Feature Branch:
bugfix/7173-upgrade-syslinux
Type of work:
Code
Blueprint:
Starter:
No
Affected tool:

Description

VirtualBox 4.1.18-dfsg-2+deb7u3: doesn't boot at all from DVD (EFI mode doesn't help). This was with an image built from commit e0a3c64
in feature/uefi. The same ISO boots fine in VirtualBox 4.3.10-dfsg-1~bpo70+1.

It seems to have been fixed in syslinux 6.03-pre5:


Related issues

Blocked by Tails - Feature #7173: Upgrade to syslinux 6.03-pre18 or later Resolved 05/08/2014

Associated revisions

Revision 078c341e (diff)
Added by Tails developers over 5 years ago

Document that boot in older VirtualBox is broken in Tails 1.1 (Closes: #7232)

History

#1 Updated by intrigeri over 5 years ago

  • Copied from Feature #7173: Upgrade to syslinux 6.03-pre18 or later added

#2 Updated by intrigeri over 5 years ago

The plan is to (try to) backport the upstream bugfix for Tails 1.1, since #7173 won't be fixed in time.

#3 Updated by intrigeri over 5 years ago

  • Parent task set to #5739

#4 Updated by intrigeri over 5 years ago

  • Status changed from Confirmed to In Progress

#5 Updated by intrigeri over 5 years ago

  • Status changed from In Progress to Confirmed
  • Target version changed from Tails_1.1 to Sustainability_M1
  • Type of work changed from Code to Documentation

intrigeri wrote:

The plan is to (try to) backport the upstream bugfix for Tails 1.1, since #7173 won't be fixed in time.

I tried to cherry-pick the two upstream commits that seemed to be relevant (e01e93b0f and a06818de2), on top of the 3:6.03~pre1+dfsg-1~bpo60+1 package we have in devel). The resulting ISO displays the syslinux menu just fine, but fails to load the Linux kernel.

So, I'm giving up for 1.1, and will instead document this problem in the known issues.

#6 Updated by intrigeri over 5 years ago

  • Copied from deleted (Feature #7173: Upgrade to syslinux 6.03-pre18 or later)

#7 Updated by intrigeri over 5 years ago

  • Blocked by Feature #7173: Upgrade to syslinux 6.03-pre18 or later added

#8 Updated by intrigeri over 5 years ago

  • Copied to Feature #7280: Document that boot in older VirtualBox is broken in Tails 1.1 added

#9 Updated by intrigeri over 5 years ago

  • Type of work changed from Documentation to Code

#10 Updated by intrigeri over 5 years ago

  • Copied to deleted (Feature #7280: Document that boot in older VirtualBox is broken in Tails 1.1)

#11 Updated by intrigeri over 5 years ago

  • Parent task deleted (#5739)

Dropping the parent task, since that one is for 1.1, while this ticket is for later.

#12 Updated by anonym about 5 years ago

  • Status changed from Confirmed to 11
  • Assignee deleted (intrigeri)
  • Target version changed from Sustainability_M1 to Tails_1.2
  • % Done changed from 0 to 100
  • QA Check set to Pass
  • Feature Branch set to bugfix/7173-upgrade-syslinux

This is fixed in the branch bugfix/7173-upgrade-syslinux, which now has been merged.

#13 Updated by anonym about 5 years ago

  • Status changed from 11 to Resolved

#14 Updated by sajolida about 5 years ago

  • Category changed from Hardware support to Virtualization

Also available in: Atom PDF