Project

General

Profile

Feature #7212

Try running our automated test suite in a Jessie environment

Added by intrigeri almost 6 years ago. Updated over 5 years ago.

Status:
Resolved
Priority:
High
Assignee:
-
Category:
Test suite
Target version:
Start date:
05/10/2014
Due date:
% Done:

100%

Feature Branch:
Type of work:
Test
Blueprint:
Starter:
No
Affected tool:

Description

It would be good, for making a decision on #6400, to evaluate how much our custom Ruby/RJB/Sikuli adapter breaks with Jessie, if at all.


Related issues

Blocks Tails - Feature #6400: Add Rjb support to ruby-sikuli Rejected 11/03/2013
Blocks Tails - Feature #8165: Make our automated test suite run in a Jessie environment Resolved 10/20/2014

History

#1 Updated by intrigeri almost 6 years ago

#2 Updated by intrigeri almost 6 years ago

  • Assignee set to anonym
  • Target version set to Sustainability_M1

As discussed on tails-dev, making sure our test suite's dependencies won't break to often is definitely an important sustainability matter. Then, we can make a decision about #6400.

#3 Updated by intrigeri almost 6 years ago

  • Priority changed from Normal to Elevated

Blocks a ticket that has priority = elevated => raising priority accordingly.

#4 Updated by intrigeri over 5 years ago

  • Target version changed from Sustainability_M1 to Tails_1.2

Doing this after 1.2 will be too late.

#5 Updated by intrigeri over 5 years ago

  • Assignee changed from anonym to intrigeri

I'll take care of that one (being bold, and just upgrading my current testing VM to Jessie -- fingers crossed).

#6 Updated by intrigeri over 5 years ago

  • Status changed from Confirmed to In Progress
  • Assignee changed from intrigeri to anonym
  • % Done changed from 0 to 10

OK, tried it, and the xprop command that checks that virt-viewer is started always failed. With this change, it successes:

--- a/features/support/helpers/display_helper.rb
+++ b/features/support/helpers/display_helper.rb
@@ -1,3 +1,4 @@
+# -*- coding: undecided -*-

 class Display

@@ -38,11 +39,8 @@ class Display
   end

   def active?
-    p = IO.popen("xprop -display #{@x_display} " +
-                 "-name '#{@domain} (1) - Virt Viewer' 2>/dev/null")
-    Process.wait(p.pid)
-    p.close
-    $? == 0
+    system "xprop -display #{@x_display} " +
+           "-name '#{@domain} (1) - Virt Viewer' >/dev/null 2>&1" 
   end

   def stop_virtviewer

... but then, FindFailed: can not find TailsBootSplash.png on the screen.

If I run the xprop command by hand, it works fine and confirms that virt-viewer is running.

anonym, can you reproduce this? It looks like a problem in the way sikuli talks to the display.

#7 Updated by intrigeri over 5 years ago

  • Priority changed from Elevated to High

Note that it would be good to see this fixed before the Jessie freeze, in case that's a bug in Debian. Fixed packages must be uploaded by October 20, which leaves us 2 weeks to diagnose whether the bug is in Debian or in our stuff, and if the former, to get a fixed package uploaded => raising priority.

#8 Updated by anonym over 5 years ago

  • Target version changed from Tails_1.2 to Tails_1.2.1

#10 Updated by intrigeri over 5 years ago

  • Blocks Feature #8165: Make our automated test suite run in a Jessie environment added

#11 Updated by anonym over 5 years ago

  • Status changed from In Progress to Resolved
  • Assignee deleted (anonym)
  • % Done changed from 10 to 100

The automated test suite runs fine in Jessie after some adjustments (will post what I discovered to #8165). To be clear, AFAICT, nothing is wrong with the state of the packages in Jessie.

Also available in: Atom PDF