Project

General

Profile

Bug #7183

Feature #5821: Switch to systemd as pid 1

Fix memory erasure when booted with systemd

Added by intrigeri about 5 years ago. Updated almost 4 years ago.

Status:
Resolved
Priority:
Normal
Assignee:
Category:
-
Target version:
-
Start date:
05/09/2014
Due date:
06/01/2015
% Done:

100%

Feature Branch:
feature/jessie
Type of work:
Code
Blueprint:
Starter:
No
Affected tool:

Description

systemd handles kexec in a different way than sysvinit, so we have to adapt our stuff a bit:


Related issues

Related to Tails - Feature #7468: Replace our memory erasure implementation with the wiperam package Rejected 06/29/2014
Duplicated by Tails - Bug #8099: Memory wipe skipped on Power Off in Jessie Duplicate 10/13/2014

History

#1 Updated by intrigeri almost 5 years ago

  • Description updated (diff)

#2 Updated by intrigeri almost 5 years ago

  • Related to Feature #7468: Replace our memory erasure implementation with the wiperam package added

#3 Updated by intrigeri over 4 years ago

kexec-tools 1:2.0.7-2 and 1:2.0.7-3 supposedly add some systemd support. Is it good enough for our needs?

#4 Updated by intrigeri over 4 years ago

  • Assignee set to intrigeri

#5 Updated by intrigeri over 4 years ago

  • Duplicated by Bug #8099: Memory wipe skipped on Power Off in Jessie added

#6 Updated by intrigeri over 4 years ago

Memory seems to be erased with kexec-tools 1:2.0.7-3 (currently in sid): screen corrupted, seems to be a cursor moving fast, and takes more time to shutdown. Not tested the emergency trigger, though.

#7 Updated by intrigeri over 4 years ago

  • Status changed from Confirmed to Resolved
  • % Done changed from 0 to 100
  • Feature Branch set to feature/jessie

Tested manually, it works.

#8 Updated by sajolida almost 4 years ago

  • Due date set to 06/01/2015

#9 Updated by sajolida almost 4 years ago

  • Target version deleted (Sustainability_M1)

Also available in: Atom PDF