Project

General

Profile

Feature #7180

Remove the right pane of WhisperBack

Added by sajolida about 5 years ago. Updated 11 months ago.

Status:
Resolved
Priority:
Normal
Assignee:
-
Category:
-
Target version:
Start date:
05/09/2014
Due date:
% Done:

100%

Feature Branch:
saschamarkus/whisperback:feature/7180-remove-right-pane
Type of work:
Code
Blueprint:
Starter:
Yes
Affected tool:
WhisperBack

Description

During the discussion around #6992, the proposal of removing the right pane of WhisperBack arose. It is currently used to:

  • Link to the bug reporting guidelines
  • Display info about email address
  • Browser the documentation

I think all those three functions could be better achieved without having them in a separate pane and integrated in a linear workflow from the top to the bottom of the window:

  • The link to the bug reporting guidelines could be integrated at the top of the window, or provided in a dialog message when starting WhisperBack.
  • The information about why providing an email address could be made shorter and inserted right before the email field.
  • Browsing the documentation in the right pane is quite uncomfortable, and could be replaced by opening a proper browser.

That needs some more UI research and prototypes.

0002-feature-7180-Remove-right-pane-of-WhisperBack.patch View (4.03 KB) sascha.markus@gmail.com, 03/28/2018 10:17 PM

sascha.png View (44.2 KB) sajolida, 04/17/2018 07:12 AM

feature-7180-Remove-right-pane-of-WhisperBack.patch View (13.8 KB) sascha.markus@gmail.com, 05/02/2018 08:49 PM

Screenshot-feature-7180-Remove-right-pane.png View (96.7 KB) sascha.markus@gmail.com, 05/02/2018 08:51 PM

alignment.png View (16 KB) sajolida, 05/15/2018 05:51 PM

Screenshot from 2018-05-15 21-42-07.png View (97.3 KB) sascha.markus@gmail.com, 05/15/2018 09:47 PM


Related issues

Related to Tails - Feature #6992: Put it more clearly that most bug reports without an email address are useless Resolved 03/30/2014
Related to Tails - Bug #11059: WhisperBack doesn't fit on a small screen Resolved 02/05/2016
Related to Tails - Feature #11689: WhisperBack: Enforce 70 character limit on the user written messages Resolved 08/22/2016
Blocks Tails - Feature #15392: Core work 2018Q2 → 2018Q3: User experience Resolved 03/09/2018

Associated revisions

Revision 0b1e92b6 (diff)
Added by Tails developers about 5 years ago

Remove about/anonymity (Closes: #7180)

Revision c9f3bec3
Added by intrigeri about 1 year ago

Merge remote-tracking branch 'saschamarkus/feature/8514-Replace-WhisperBack.mail_appended_info-with-a-dictionary' into feature/8514-7180-whisperback-remove-right-pane-and-refactor (refs: #8514, #7180)

Revision d24273ff
Added by intrigeri 11 months ago

Merge branch 'feature/8514-7180-whisperback-remove-right-pane-and-refactor' into devel (Fix-committed: #8514, #7180)

History

#1 Updated by sajolida about 5 years ago

  • Related to Feature #6992: Put it more clearly that most bug reports without an email address are useless added

#2 Updated by intrigeri almost 5 years ago

  • Type of work changed from Research to User interface design

#3 Updated by sajolida over 3 years ago

  • Related to Bug #11059: WhisperBack doesn't fit on a small screen added

#4 Updated by u over 1 year ago

  • Assignee set to sajolida
  • QA Check set to Info Needed

Is this still something we want?

#5 Updated by sajolida over 1 year ago

  • Assignee deleted (sajolida)
  • Priority changed from Normal to Low
  • QA Check deleted (Info Needed)

Sure. But moving to low prio until we know who's going to write the code.

#6 Updated by sascha.markus@gmail.com over 1 year ago

This patch removes the right pane by moving the content to a third tab.

#7 Updated by intrigeri over 1 year ago

  • Assignee set to sajolida
  • Priority changed from Low to Normal
  • QA Check set to Ready for QA

That needs some more UI research and prototypes.
[…]
But moving to low prio until we know who's going to write the code.

Now we have someone ready to write some code and a prototype (see the attached patch :)
I guess next step is you review the proposed UI, right?

#8 Updated by sajolida over 1 year ago

  • File sascha.png View added
  • Assignee changed from sajolida to sascha.markus@gmail.com
  • QA Check changed from Ready for QA to Dev Needed

Hi Sascha, thanks a lot for the patch!

I'm putting in attachment how WhisperBack look with your changes.

I'm proposing something quite different in the description of this ticket. I don't like the idea of moving all this information to a different tab as you did because, instead of simplyfing and integrating the same information better in the flow of reporting the bug, creating a new tag moves it even further away from the user.

I'll rephrase and elaborate on my proposal:

1. Improve the label of the email address field. I propose:

Email address (if you want an answer)

Which still makes it clear that the email address is optional while insisting on why giving it is useful to the user.

2. Add a link below "Bug description":

Read our bug reporting guidelines.

Which would open the following link in the browser:

https://tails.boum.org/doc/first_steps/bug_reporting/

3. Remove the right pane.

#9 Updated by sajolida over 1 year ago

  • Blocks Feature #15392: Core work 2018Q2 → 2018Q3: User experience added

#10 Updated by sascha.markus@gmail.com about 1 year ago

Here is a new patch
- Below the bug description a link to the reporting guidelines is added
- The text for the label is changed
- The right panel and it's content is removed

#11 Updated by sascha.markus@gmail.com about 1 year ago

  • Status changed from Confirmed to In Progress
  • Assignee changed from sascha.markus@gmail.com to sajolida
  • QA Check deleted (Dev Needed)

#12 Updated by sajolida about 1 year ago

  • Target version set to Tails_3.7
  • QA Check set to Ready for QA
  • Starter changed from No to Yes

Thanks for the updated patch sascha! I'll have a look soon.

#13 Updated by sajolida about 1 year ago

  • Target version changed from Tails_3.7 to Tails_3.8

#14 Updated by sajolida about 1 year ago

  • Related to Feature #11689: WhisperBack: Enforce 70 character limit on the user written messages added

#15 Updated by sajolida about 1 year ago

  • File alignment.png View added
  • Assignee changed from sajolida to sascha.markus@gmail.com
  • Target version changed from Tails_3.8 to Tails_3.9
  • QA Check changed from Ready for QA to Dev Needed

Great!

Two minor things:

  • I had a hard time applying your patch. I managed to apply it on top of 35b97c9 and test it from there. I tried to resolve conflicts when merging with master but then WhisperBack wouldn't start. I pushed your patch to the branch feature/7180-remove-right-pane. Can you resolve the merge conflicts with master in there?
  • Is it possible to align the "Read our [...]" to the left. See screenshot in attachment.

This change is too big to be included in 3.8 so I'm marking it for 3.9 which is our next major release.

#16 Updated by sascha.markus@gmail.com about 1 year ago

Hi sajolida,
sorry to hear that it was hard to apply the patch. With a small change it's working now in the branch.

But I didn't manage to move the link to the left yet. There is an unvisible but clickable border around the link text.

But what about a label in front of the link to have the correct alignment?
Please have a look at the attached screenshot.

And an additional thing:
To play around with the layout I installed Glade.
When I open data/whisperback.ui there is a message about the old version (<requires lib="gtk+" version="2.20"/>)
After closing this message I see several warnings about deprecated element like GtkVBox.
1) Should I upgrade to a more recent GTK version?
Tails 3.7 comes with:
libgtk-3-0:amd64 3.22.11-1.0tails1 amd64
libgtk-3-common 3.22.11-1.0tails1 all

2) Should I replace the deprecated elements with the correct ones?

The attached screenshot was created with GTK version 3.22 and without any deprecated elements.

#17 Updated by sajolida about 1 year ago

  • QA Check changed from Dev Needed to Info Needed

Sascha: Where can I find the code for your new changes:

  • How to merge your work on this ticket into master?
  • The code to have a label in from of the link.

If you need some Git hosting for your repo, you could create yourself a public repo on GitHub, GitLab, or 0xacab.org.

Other than that, if nobody else can fix the left alignment problem, I'm fine with either leaving it as it is now in the last code that I reviewed or adding a label as you did in your screenshot.

So I'm reassign this ticket to you so we have your last code but then I'll hand over the ticket to someone who can review and merge the code now that I'm happy with the UI. They should also mentor you regarding the GTK upgrade that you are mentioning.

#18 Updated by sascha.markus@gmail.com about 1 year ago

  • Assignee changed from sascha.markus@gmail.com to sajolida
  • QA Check changed from Info Needed to Ready for QA

Hi,
here is a mirror of the whisperback repo https://github.com/saschamarkus/whisperback
It contains the label to have the elements aligned.
Your branch is merged into master in this repo and it works fine when I build it in my tails enviroment.

#19 Updated by sajolida about 1 year ago

  • Assignee deleted (sajolida)

Hi again Sascha. Thanks for the Git branch! It's much easier for me to review like this.

I'm happy with the interface now and I'm marking it as waiting for a code review.

I think we should target 3.8 as it's quite a big change but it would be good to have a first code review by 3.8, in case you need to go more work.

To whoever will review this: please read #7180#note-16 in details and answer Sascha's concerns regarding Gtk.

#20 Updated by intrigeri about 1 year ago

  • Assignee set to intrigeri

I'm happy with the interface now and I'm marking it as waiting for a code review.

… which I'll do!

#21 Updated by intrigeri about 1 year ago

sajolida wrote:

I think we should target 3.8 as it's quite a big change

I'll assume you mean "we should target 3.9".

#22 Updated by intrigeri about 1 year ago

  • Feature Branch set to saschamarkus/whisperback:7180-remove-right-pane

#23 Updated by intrigeri about 1 year ago

  • Feature Branch changed from saschamarkus/whisperback:7180-remove-right-pane to saschamarkus/whisperback:feature/7180-remove-right-pane

#24 Updated by intrigeri about 1 year ago

wrote:

When I open data/whisperback.ui there is a message about the old version (<requires lib="gtk+" version="2.20"/>)
After closing this message I see several warnings about deprecated element like GtkVBox.
1) Should I upgrade to a more recent GTK version?
Tails 3.7 comes with:
libgtk-3-0:amd64 3.22.11-1.0tails1 amd64
libgtk-3-common 3.22.11-1.0tails1 all

2) Should I replace the deprecated elements with the correct ones?

Yes, please :)

#25 Updated by intrigeri about 1 year ago

  • Assignee changed from intrigeri to sascha.markus@gmail.com
  • % Done changed from 0 to 50
  • QA Check changed from Ready for QA to Dev Needed

Code review passes. I'll test and merge once the GTK version thing is solved :)

#26 Updated by sascha.markus@gmail.com about 1 year ago

  • Assignee changed from sascha.markus@gmail.com to intrigeri
  • % Done changed from 50 to 80
  • QA Check changed from Dev Needed to Ready for QA

Hi,
please check https://github.com/saschamarkus/whisperback/tree/feature/7180-remove-right-pane
I applied the changes necessary to get rid of the deprecated messages in Glade and also to remove some warnings when using the app.

#27 Updated by intrigeri about 1 year ago

  • Assignee changed from intrigeri to sascha.markus@gmail.com
  • QA Check changed from Ready for QA to Dev Needed
  • Type of work changed from User interface design to Code

Almost there!

  • I see that sajolida has pushed a few string improvements to https://git-tails.immerda.ch/whisperback/log/?h=feature/7180-remove-right-pane. Can you please merge his branch?
  • Please merge current master into your topic branch as they currently conflict.
  • I suspect the string "If you want us to encrypt…" should not be split over two lines (especially with a trailing space). If that was not done on purpose, please merge them back into one single line.
  • It seems we don't use webkit anymore so all references to gir1.2-webkit-3.0 should be dropped from debian/control. I can do this myself when merging if you prefer.
  • Please see my comment on #8514 wrt. Git history.

#28 Updated by sascha.markus@gmail.com about 1 year ago

  • Assignee changed from sascha.markus@gmail.com to intrigeri
  • QA Check changed from Dev Needed to Ready for QA

OK,
- both merges are done
- WebKit is removed from debian/control
- label is back in one line
- smaller commits

I build and installed it in tails and everything seems to be fine.
Please check https://github.com/saschamarkus/whisperback/tree/feature/7180-remove-right-pane

#29 Updated by intrigeri about 1 year ago

Code review passes! I'll test soon.

Hint to create atomic commits: git add -p is your friend :)

#30 Updated by intrigeri about 1 year ago

Merged this + #8514 into a feature/8514-7180-whisperback-remove-right-pane-and-refactor integration branch (both in tails.git and whisperback.git), built & uploaded a package.

#31 Updated by intrigeri about 1 year ago

  • Status changed from In Progress to Fix committed
  • Assignee deleted (intrigeri)
  • % Done changed from 80 to 100
  • QA Check changed from Ready for QA to Pass

I tested this and it looks fine. I've merged your branch into WhisperBack's master branch so it'll be part of the next WhisperBack release. I'll skip that for 3.8 which is a bugfix release so it should land in 3.9.

#32 Updated by intrigeri 11 months ago

  • Status changed from Fix committed to Resolved

Also available in: Atom PDF