Project

General

Profile

Bug #7175

Feature #6315: Make it possible to deploy and run our test suite

Sikuli is broken with openjdk 6b31-1.13.3-1~deb7u1

Added by anonym about 5 years ago. Updated almost 5 years ago.

Status:
Resolved
Priority:
Elevated
Assignee:
-
Category:
Test suite
Target version:
Start date:
06/21/2014
Due date:
% Done:

100%

Feature Branch:
bugfix/7175-openjdk-7
Type of work:
Code
Blueprint:
Starter:
No
Affected tool:

Description

After upgrading (on Wheezy) openjdk from 6b27-1.12.6-1~deb7u1 to 6b31-1.13.3-1~deb7u1 (to fix DSA-2912-1) sikuli cannot initialize in our automated test suite. I get the following error:

no VisionProxy in java.library.path (UnsatisfiedLinkError)
/home/anonym/src/tails-master/features/support/helpers/sikuli_helper.rb:24:in `import'
[...]

Reverting back to the following packages and versions fixes the issue:

  • icedtea-6-jre-cacao:amd64 6b27-1.12.6-1~deb7u1
  • openjdk-6-jre-lib:amd64 6b27-1.12.6-1~deb7u1
  • openjdk-6-jre-headless:amd64 6b27-1.12.6-1~deb7u1
  • icedtea-6-jre-jamvm:amd64 6b27-1.12.6-1~deb7u1
  • openjdk-6-jdk:amd64 6b27-1.12.6-1~deb7u1
  • openjdk-6-jre:amd64 6b27-1.12.6-1~deb7u1

The following launchpad bug may be relevant, but offer little in terms of details and solutions (at least it indicates that it's a general issue not related to e.g. us using ruby-rjb): https://answers.launchpad.net/sikuli/+question/242313

Can someone else please confirm this (optimistically assigning to intrigeri since I know he's got a working test suite setup)? Then I suppose we should at least file a Debian bug.


Subtasks

Feature #7428: Reproduce test suite problem with openjdk 6b31-1.13.3-1~deb7u1Resolvedintrigeri

Associated revisions

Revision 5de18e23 (diff)
Added by Tails developers almost 5 years ago

Use OpenJDK 7 to run our test suite (Closes #7175).

... and accordingly update the setup documentation.

History

#1 Updated by intrigeri about 5 years ago

Can someone else please confirm this (optimistically assigning to intrigeri since
I know he's got a working test suite setup)? Then I suppose we should at least file
a Debian bug.

Please file a Debian bug first: a regression in stable is a serious
matter, and the relevant maintainers should be made aware of it ASAP.

Then, I'll try to reproduce this (no idea if this can happen before
1.1, and we should definitely not be blocking on this to report a bug
to the right people).

#2 Updated by intrigeri about 5 years ago

  • Assignee changed from intrigeri to anonym
  • Priority changed from Normal to Elevated

#3 Updated by intrigeri about 5 years ago

  • Status changed from New to Confirmed
  • Parent task set to #6315

#4 Updated by anonym about 5 years ago

#5 Updated by intrigeri about 5 years ago

  • Type of work changed from Upstream to Debian

#6 Updated by BitingBird about 5 years ago

  • Target version set to Hole in the Roof

parent ticket is hole in the roof -> target version for the subtasks :)

#7 Updated by intrigeri about 5 years ago

I could reproduce this bug, and workaround it by using openjdk-7 instead of openjdk-6:

--- a/run_test_suite
+++ b/run_test_suite
@@ -180,7 +180,7 @@ if [ -n "${VNC_VIEWER}" ]; then
     start_vnc_viewer
 fi

-export JAVA_HOME="/usr/lib/jvm/java-6-openjdk-amd64" 
+export JAVA_HOME="/usr/lib/jvm/java-7-openjdk-amd64" 
 export SIKULI_HOME="/usr/share/java" 
 export DISPLAY=${TARGET_DISPLAY}
 check_dependency cucumber

I think that's the way to go, and will be a nice first step on the road to #7212.
This also requires updating the test suite setup instructions.

#8 Updated by intrigeri almost 5 years ago

  • Assignee changed from anonym to intrigeri
  • Type of work changed from Debian to Code

#9 Updated by intrigeri almost 5 years ago

  • Status changed from Confirmed to In Progress
  • Assignee changed from intrigeri to anonym
  • QA Check set to Ready for QA
  • Feature Branch set to bugfix/7175-openjdk-7

#10 Updated by anonym almost 5 years ago

  • Status changed from In Progress to Fix committed
  • Assignee deleted (anonym)
  • Target version changed from Hole in the Roof to Tails_1.1
  • QA Check changed from Ready for QA to Pass

#11 Updated by BitingBird almost 5 years ago

  • Status changed from Fix committed to Resolved

Also available in: Atom PDF