Project

General

Profile

Feature #7162

Update the ISO verification instructions using GNOME

Added by sajolida about 5 years ago. Updated about 4 years ago.

Status:
Resolved
Priority:
Elevated
Assignee:
Category:
Installation
Target version:
Start date:
Due date:
% Done:

100%

QA Check:
Feature Branch:
doc/7162-gnome_verif
Type of work:
End-user documentation
Blueprint:
Starter:
No
Affected tool:

Description

In our ISO verification instructions for GNOME we advertise the use of
OpenPGP through seahorse-plugins, but that used to be broken on recent
Debian and Ubuntu.

intrigeri reported that:

  • It works fine in testing/sid.
  • For Wheezy, one needs to install seahorse-nautilus + shared-mime-info
    from the backports, then it works just fine.

Status for Ubuntu should be investigated and updated.


Related issues

Related to Tails - Feature #8580: Installation Assistant Resolved 04/07/2014 05/20/2015
Related to Tails - Bug #6851: Fix ISO verification using checksum Resolved 08/16/2013

Associated revisions

Revision a2ff0a1b (diff)
Added by intrigeri about 4 years ago

Make it clear that having seahorse-nautilus is not enough in itself.

E.g. in Ubuntu Trusty and Utopic, the version of seahorse-nautilus won't
work because a recent enough shared-mime-info isn't available.

Will-fix: #7162

Revision f71268b9
Added by sajolida about 4 years ago

Merge branch 'doc/7162-gnome_verif' (Closes: #7162)

History

#1 Updated by intrigeri almost 5 years ago

  • Starter set to No

IMO this ticket would be worth priority = Elevated.

#2 Updated by BitingBird over 4 years ago

  • Priority changed from Normal to Elevated

#3 Updated by BitingBird over 4 years ago

  • Category set to Installation

#4 Updated by sajolida over 4 years ago

#5 Updated by BitingBird over 4 years ago

  • Related to Bug #6851: Fix ISO verification using checksum added

#6 Updated by BitingBird about 4 years ago

  • Assignee set to BitingBird
  • Target version set to Tails_1.3.2

#7 Updated by BitingBird about 4 years ago

  • Status changed from Confirmed to In Progress
  • Feature Branch set to bitingbird:doc/7162-gnome_verif

#8 Updated by BitingBird about 4 years ago

  • Assignee changed from BitingBird to sajolida
  • QA Check set to Ready for QA

Corrected the doc. I separated the instructions on Wheezy and on Jessie. Please review :)

#9 Updated by sajolida about 4 years ago

  • Assignee changed from sajolida to BitingBird
  • QA Check changed from Ready for QA to Dev Needed
  • People in Wheezy should install seahorse-nautilus and shared-mime-info from backports, so if you do a special section for Wheezy, there's no point in mentioning backports in a note after the apt-get command.
  • To which versions of Ubuntu does the backport thingie applies? Does Ubuntu even have that notion of backports? Because that's what you first section seems to pretend.
  • Could you be more precise than "recent Ubuntu"? Which version of Ubuntu has the right package? What do you need to do if you have an older Ubuntu version than that (if relevant)?
  • With the new structure of your page the content of the second note seems redundant with your new first section.

In the end, I'm not sure it's a good idea to do two sections. The only thing that's specific about Wheezy is that you need to install those packages from backports. Do you think we should go into the details of explaining how to use backports? And regarding Ubuntu what needs to be clarified is starting from which version do we have the good package.

#10 Updated by BitingBird about 4 years ago

  • Assignee changed from BitingBird to sajolida
  • QA Check changed from Dev Needed to Ready for QA

Reworked it all. Added specific Ubuntu versions, removed older Ubuntu (doesn't work -> command-line), and reorganized in a more logical way. Also removed the strange list that didn't look good (the page is too long for a list to make sense).

Built 10 times, the last version looks good :) Please review!

#11 Updated by BitingBird about 4 years ago

  • Target version changed from Tails_1.3.2 to Tails_1.4

#13 Updated by intrigeri about 4 years ago

  • % Done changed from 0 to 60
  • Feature Branch changed from bitingbird:doc/7162-gnome_verif to doc/7162-gnome_verif

I've pushed a few important fixes, and a lot of minor changes, to doc/7162-gnome_verif. It now looks good enough to me, but still I'd like sajolida to give it a last glance before it's merged.

#14 Updated by sajolida about 4 years ago

  • Status changed from In Progress to Resolved
  • % Done changed from 60 to 100

#15 Updated by sajolida about 4 years ago

  • QA Check deleted (Ready for QA)

Merged, thanks!

#16 Updated by BitingBird about 4 years ago

Thanks !

Also available in: Atom PDF