Project

General

Profile

Feature #7143

Feature #5977: Adapt documentation from Incognito

Rework /doc/advanced_topics/virtualization/

Added by sajolida about 5 years ago. Updated over 4 years ago.

Status:
Resolved
Priority:
Normal
Assignee:
-
Category:
Virtualization
Target version:
Start date:
04/30/2014
Due date:
% Done:

100%

QA Check:
Pass
Feature Branch:
doc/7143-virtualization
Type of work:
End-user documentation
Blueprint:
Starter:
No
Affected tool:

Description

- Simplify text
- Simplify the subpages to fit on a single page
- Fix the information about running Tails from Windows
- Fix markup
- List more virtualization solutions
- Mention VirtualBox limitations and bugs
- Mention libvirt


Related issues

Related to Tails - Feature #8089: Test Tails in GNOME Boxes Resolved 10/13/2014
Related to Tails - Bug #7695: No network with VirtualBox, Bridged Mode, and MAC Spoofing Rejected 07/31/2014
Blocked by Tails - Feature #5636: Document how to access internal hard disks Resolved

Associated revisions

Revision 8ad77fa0
Added by Tails developers over 4 years ago

Merge remote-tracking branch 'origin/doc/7143-virtualization' (Closes: #7143).

History

#1 Updated by sajolida about 5 years ago

  • Assignee set to sajolida

#2 Updated by sajolida almost 5 years ago

  • Target version changed from Tails_1.1 to Tails_1.2

#3 Updated by sajolida over 4 years ago

Is it worth mentioning that the network traffic emitted by the host operating system will unchanged (non-Torified, "safe", etc.)?

This question was raised on the forum: "Is it safe to use the Internet on my host computer (not connected to Tor network)?".

#4 Updated by sajolida over 4 years ago

Mention MAC changing

#5 Updated by sajolida over 4 years ago

Explain how to use libvirt to start from a USB with persistence.

#6 Updated by sajolida over 4 years ago

The content of the RAM of the VM can end up on the hard disk of the host if swapped.

#7 Updated by sajolida over 4 years ago

  • Target version changed from Tails_1.2 to Hole in the Roof

#8 Updated by sajolida over 4 years ago

#9 Updated by intrigeri over 4 years ago

  • Category set to Hardware support

#10 Updated by sajolida over 4 years ago

  • Category changed from Hardware support to Virtualization

#11 Updated by sajolida over 4 years ago

  • Related to Bug #7695: No network with VirtualBox, Bridged Mode, and MAC Spoofing added

#12 Updated by sajolida over 4 years ago

  • Assignee changed from sajolida to intrigeri
  • Target version changed from Hole in the Roof to Tails_1.3
  • QA Check set to Ready for QA
  • Feature Branch set to doc/7143-virtualization

Ready for a first review, probably not a merge :)

#13 Updated by sajolida over 4 years ago

  • Status changed from Confirmed to In Progress
  • % Done changed from 0 to 40

#14 Updated by BitingBird over 4 years ago

Looked at it but didn't test it. Looked good.

#15 Updated by intrigeri over 4 years ago

  • Assignee changed from intrigeri to sajolida
  • QA Check changed from Ready for QA to Dev Needed

#16 Updated by sajolida over 4 years ago

  • Blocked by Feature #5636: Document how to access internal hard disks added

#17 Updated by intrigeri over 4 years ago

  • % Done changed from 40 to 80
  • QA Check changed from Dev Needed to Pass

#18 Updated by intrigeri over 4 years ago

  • QA Check changed from Pass to Dev Needed

Only remaining thing to do: point to the piece of doc about the risks of accessing the local hard disk from Tails (#5636).

#19 Updated by sajolida over 4 years ago

  • Priority changed from Normal to Elevated

#20 Updated by sajolida over 4 years ago

Now that #5636 suits me, I polished a bit this branch as well so we can merge both at the same time hopefully.

#21 Updated by sajolida over 4 years ago

  • Assignee changed from sajolida to intrigeri
  • Priority changed from Elevated to Normal

Assigning to intrigeri who has been doing the review work so far.

#22 Updated by intrigeri over 4 years ago

  • QA Check changed from Dev Needed to Ready for QA

Looks like this should be flagged as ready for QA.

#23 Updated by intrigeri over 4 years ago

Added commit:d08df16 on top (please have a look), will now merge.

#24 Updated by Tails over 4 years ago

  • Status changed from In Progress to Resolved
  • % Done changed from 80 to 100

Applied in changeset commit:69dd8b13c85e749ba014a4e4bf2444b1db22102f.

#25 Updated by intrigeri over 4 years ago

  • Assignee deleted (intrigeri)
  • QA Check changed from Ready for QA to Pass

Also available in: Atom PDF