Project

General

Profile

Bug #7131

Feature #7019: Better support writable boot devices with read-only switch

Incremental upgrades: test if the USB stick is read-only

Added by alant over 5 years ago. Updated over 5 years ago.

Status:
Confirmed
Priority:
Normal
Assignee:
-
Category:
-
Target version:
-
Start date:
04/28/2014
Due date:
% Done:

0%

Feature Branch:
Type of work:
Code
Blueprint:
Starter:
No
Affected tool:
Upgrader

Description

When accepting to upgrade with a read-only USB device, the error message is generic and points to .xsession-errors which doesn't give a clue. That should be improved.

Error while installing the upgrade

An error occured while installing the upgrade.

Your Tails device needs to be repaired and might be unable to restart.

Please follow the instructions at file:///usr/share/doc/tails/website/doc/upgrade/error/install.en.html

For debugging information, see /home/amnesia/.xsession-errors

$ tail .xsession-errors

localuser:tails-upgrade-frontend being added to access control list
glibtop: Non-standard uts for running kernel:
release 3.12-1-amd64=3.12.0 gives version code 199680

The system is up-to-date
localuser:tails-upgrade-frontend being removed from access control list
** Message: NM disappeared

History

#1 Updated by intrigeri over 5 years ago

  • Status changed from New to Confirmed
  • Parent task set to #7019

#2 Updated by BitingBird over 5 years ago

  • Description updated (diff)

#3 Updated by BitingBird over 5 years ago

  • Subject changed from Incremental upgrades: unclear message if the USB stick is RO to Incremental upgrades: test if the USB stick is RO

The problem is not the message

#4 Updated by intrigeri over 5 years ago

  • Subject changed from Incremental upgrades: test if the USB stick is RO to Incremental upgrades: test if the USB stick is read-only

Also available in: Atom PDF