Project

General

Profile

Feature #7129

Security check could also warn when using a RC or testing version

Added by sajolida over 5 years ago. Updated almost 5 years ago.

Status:
Confirmed
Priority:
Low
Assignee:
-
Category:
-
Target version:
-
Start date:
04/28/2014
Due date:
% Done:

0%

Feature Branch:
Type of work:
Code
Blueprint:
Starter:
No
Affected tool:
Security Check

Description

In the same way as tails-security-check warns users if they use an outdated version, it could also warn them if they use a RC or testing version.

History

#1 Updated by intrigeri over 5 years ago

I'm afraid I don't clearly get why. Care to elaborate?

#2 Updated by sajolida over 5 years ago

I'm afraid I don't clearly get why. Care to elaborate?

Why? To make sure they see every time they start Tails that the version
they use is not reliable. We try to always mention this in the call for
testing or other places where we point to RC or other testing versions,
like user support, but this communication might fail.

Insisting a bit more, since we already have a mechanism that could be
adapted to do that, might be worth it. The version of Tails that you are
using is not prominently displayed when you start, so you might as well
confuse a testing Tails device for another or clone from someone running
a RC, etc.

#3 Updated by intrigeri over 5 years ago

  • Status changed from New to Confirmed
  • Priority changed from Normal to Low
  • Type of work changed from Discuss to Code

Thanks for the explanation, I'm now convinced if would be code worth maintaining (assuming we get a patch). If someone volunteers to implement it, feel free to raise priority to Normal.

#4 Updated by intrigeri almost 5 years ago

  • Affected tool set to Security Check

Also available in: Atom PDF