Project

General

Profile

Bug #7118

Document that "Securely clean available disk space" does not delete hidden files

Added by matsa over 5 years ago. Updated over 4 years ago.

Status:
Resolved
Priority:
Normal
Assignee:
-
Category:
-
Target version:
Start date:
04/19/2014
Due date:
% Done:

100%

Feature Branch:
doc/7118-erase_available_disk_warning
Type of work:
End-user documentation
Blueprint:
Starter:
No
Affected tool:

Description

Users cleaning available disk space* should be warn that sfill does not take hidden files in account, i.e previously delete files can still appear in trash folders.

This could be .trash folders from *nix, but also .DS_Store, ~/.Trash, /.Spotlight-V100 and others

wipe_available_diskspace.png View (55.5 KB) sajolida, 12/11/2014 12:49 PM


Related issues

Related to Tails - Feature #5831: Warn against file wiping shortcomings Resolved

Associated revisions

Revision a87a80e6
Added by Tails developers over 4 years ago

Merge branch 'doc/7118-erase_available_disk_warning' (Closes: #7118)

Conflicts:
wiki/src/doc/encryption_and_privacy/secure_deletion.mdwn

History

#1 Updated by sajolida over 5 years ago

  • Status: Confirmed

#2 Updated by intrigeri over 5 years ago

  • Status changed from New to Confirmed

#3 Updated by intrigeri over 5 years ago

  • Subject changed from Securely clean available disk space does not delete hidden files to Document that "Securely clean available disk space" does not delete hidden files

#4 Updated by intrigeri over 5 years ago

  • Related to Feature #5831: Warn against file wiping shortcomings added

#5 Updated by BitingBird almost 5 years ago

  • Status changed from Confirmed to In Progress
  • Assignee set to sajolida
  • Target version set to Tails_1.2.2
  • QA Check set to Ready for QA
  • Feature Branch set to bitingbird:doc/7118-erase_available_disk_warning

#6 Updated by sajolida almost 5 years ago

First, your branch bitingbird:doc/7118-erase_available_disk_warning is mixing up many commits from other tickets such as ff4c094 from #7226, 7e182cd from #7357, etc.

So I created a branch on our main Git base directly on master (as of today) and added your relevant commit on top of it.

When working on this again, if you didn't do more work on it, please try to do reset your local branch to this one:

  • git fetch (to fetch the latest changes to our main repo)
  • git checkout doc/7118-erase_available_disk_warning (to put yourself on your branch)
  • git reset --hard origin/doc/7118-erase_available_disk_warning (to reset your branch to the state of the one in our main repo).

In the future, please make sure that the difference between your branch and master only matches the ticket that you are trying to address. To do so you can do:

  • git diff origin/master.. (to see the raw difference between origin/master and your branch)
  • git log -p origin/master.. (to see the Git log between origin/master and your branch)

Then regarding your work, I would explain people how to see hidden files. because the technical Unix explanation that "files and folders whose name
+start with . are hidden" is not enough if you only work through GUI. In Nautilus you can do View → Show hidden files.

Then, those hidden files can also be present in any parent or sub folder on that disk. So what about explaining this as well?

Regarding the hidden trash folder, I would give an example. The currrent document could actually be improved maybe. Instead of saying "2. Navigate to a folder on the disk that you want to clean." we could instead explain how to do directly to the root of that disk (clicking on the corresponding disk in the left pane). Then, if would easier to explain the hidden Trash thing as it appears on that same root.

Then I would replace the second screenshot with the one I attach to this ticket and update all the rest accordingly.

What do you think?

#7 Updated by sajolida almost 5 years ago

  • Feature Branch changed from bitingbird:doc/7118-erase_available_disk_warning to doc/7118-erase_available_disk_warning

#8 Updated by anonym almost 5 years ago

  • Target version changed from Tails_1.2.2 to Tails_1.2.3

#9 Updated by BitingBird almost 5 years ago

  • Target version changed from Tails_1.2.3 to Tails_1.3

#10 Updated by BitingBird almost 5 years ago

  • Assignee changed from BitingBird to sajolida
  • QA Check changed from Dev Needed to Ready for QA
  • Feature Branch changed from doc/7118-erase_available_disk_warning to bitingbird:doc/7118-erase_available_disk_warning

Implemented your suggestions, and the new image seems good but I don't know how to include it, I let you do that :)

#11 Updated by intrigeri almost 5 years ago

  • Assignee changed from sajolida to BitingBird
  • % Done changed from 0 to 20
  • QA Check changed from Ready for QA to Dev Needed

There are plenty of examples on our website:

find wiki/src -name '*.png'
git grep '\.png' -- wiki/src

Want to give it a try?

#12 Updated by BitingBird almost 5 years ago

  • Assignee changed from BitingBird to sajolida
  • QA Check changed from Dev Needed to Ready for QA

Nope, that's why I said "I let you do that".

#13 Updated by Tails over 4 years ago

  • Status changed from In Progress to Resolved
  • % Done changed from 20 to 100

Applied in changeset commit:bc15b460db4ee46f5ba213eeb231334bce6daf4d.

#14 Updated by sajolida over 4 years ago

  • Assignee deleted (sajolida)
  • QA Check deleted (Ready for QA)
  • Feature Branch changed from bitingbird:doc/7118-erase_available_disk_warning to doc/7118-erase_available_disk_warning

Added a bunch of improvements on top of that and merged. Frontdesk is going to be happy. Thanks!

Also available in: Atom PDF