Project

General

Profile

Bug #7104

Deal with cuddlefish-version.patch in our iceweasel

Added by anonym about 5 years ago. Updated about 5 years ago.

Status:
Resolved
Priority:
Elevated
Assignee:
-
Category:
-
Target version:
Start date:
04/17/2014
Due date:
% Done:

0%

Feature Branch:
Type of work:
Audit
Blueprint:
Starter:
No
Affected tool:
Browser

Description

When preparing 24.4.0esr-1+tails1 for 1.0~rc1 I got a new (for me) type of build error:

[...]
dpkg-source: info: local changes detected, the modified files are:
 iceweasel/addon-sdk/source/python-lib/cuddlefish/_version.py
dpkg-source: error: aborting due to unexpected upstream changes, see /tmp/iceweasel_24.4.0esr-1+tails1~bpo60+1.diff.SzGGH0
dpkg-source: info: you can integrate the local changes with dpkg-source --commit
dpkg-buildpackage: error: dpkg-source -b iceweasel gave error exit status 2
gbp:error: Couldn't run 'git-pbuilder': git-pbuilder returned 2
Command exited with non-zero status 1

----

--- iceweasel-24.4.0esr.orig/addon-sdk/source/python-lib/cuddlefish/_version.py
+++ iceweasel-24.4.0esr/addon-sdk/source/python-lib/cuddlefish/_version.py
@@ -9,8 +9,8 @@
 # (https://github.com/warner/python-versioneer)

 # these strings will be replaced by git during git-archive
-git_refnames = " (upstream/24.4.0esr)" 
-git_full = "e5c57b6ba6212d34b822e1c8787b5a04b6ad4ea7" 
+git_refnames = "$Format:%d$" 
+git_full = "$Format:%H$" 

 import subprocess

I just followed `dpkg-source`'s suggestion and commited the patch into df965fc in our iceweasel Git repo.

Any ideas of why this happened? Should it have been dealt with in another way?

History

#1 Updated by intrigeri about 5 years ago

  • Assignee changed from intrigeri to anonym

The iceweasel Vcs-Git repo is not meant to be built with gbp or git-pbuilder. I use good old pbuilder to build source packages, and have never seen this problem. Care to clarify this in https://tails.boum.org/contribute/release_process/iceweasel/ ?

#2 Updated by anonym about 5 years ago

  • Assignee changed from anonym to intrigeri

intrigeri wrote:

The iceweasel Vcs-Git repo is not meant to be built with gbp or git-pbuilder. I use good old pbuilder to build source packages, and have never seen this problem. Care to clarify this in https://tails.boum.org/contribute/release_process/iceweasel/ ?

Thanks for the clarification! The instructions have been fixed in commit e19db60 (pushed to the devel branch).

Still, what should be done with with `cuddlefish-version.patch`?

#3 Updated by intrigeri about 5 years ago

Still, what should be done with with `cuddlefish-version.patch`?

Drop the patch, retry with plain old pbuilder, and see if it is still needed?

#4 Updated by intrigeri about 5 years ago

  • Assignee changed from intrigeri to anonym

#5 Updated by anonym about 5 years ago

  • Status changed from Confirmed to Fix committed
  • Assignee deleted (anonym)
  • QA Check changed from Dev Needed to Pass

Patch was dropped as iceweasel 24.5.0esr-0+tail1* built just fine using pdebuild.

#6 Updated by anonym about 5 years ago

  • Status changed from Fix committed to Resolved

Also available in: Atom PDF