Project

General

Profile

Feature #7075

"About" page improvements

Added by BitingBird over 5 years ago. Updated almost 5 years ago.

Status:
Resolved
Priority:
Normal
Assignee:
-
Category:
-
Target version:
-
Start date:
04/12/2014
Due date:
% Done:

100%

Feature Branch:
Type of work:
Website
Blueprint:
Starter:
No
Affected tool:

Description

The "What's next?" could link to the calendar, because lots of users don't seem to find the information about when is the next version coming out. It should also link to the FAQ.

History

#1 Updated by intrigeri about 5 years ago

  • Description updated (diff)

#2 Updated by BitingBird almost 5 years ago

  • Status changed from New to Confirmed

#3 Updated by BitingBird almost 5 years ago

  • Status changed from Confirmed to In Progress
  • Assignee set to BitingBird
  • QA Check set to Ready for QA

#4 Updated by BitingBird almost 5 years ago

  • Assignee deleted (BitingBird)

#5 Updated by intrigeri almost 5 years ago

  • Status changed from In Progress to Resolved
  • % Done changed from 0 to 100
  • QA Check changed from Ready for QA to Pass

Also available in: Atom PDF