Project

General

Profile

Bug #6993

Provide a nginx configuration sample for mirrors

Added by geb over 5 years ago. Updated almost 5 years ago.

Status:
Resolved
Priority:
Low
Assignee:
-
Category:
Infrastructure
Target version:
-
Start date:
03/30/2014
Due date:
% Done:

0%

Feature Branch:
Type of work:
End-user documentation
Blueprint:
Starter:
No
Affected tool:

Description

On https://tails.boum.org/contribute/how/mirror/#index5h2 there is documentation for apache and lighttpd, but no nginx.

It should be nice to add an nginx one, like

server {
  listen   [::]:80;
  server_name dl.amnesia.boum.org;
  root /var/www/THE_PLACE_WHERE_YOU_WANT_OUR_FILES_TO_LIVE;
  location / {
    autoindex on;
  }
}

Configuration not tested but provided by petrus. Thanks to him.

Associated revisions

Revision d379bca6 (diff)
Added by Tails developers over 5 years ago

Add nginx configuration example for mirrors (Closes: #6993).

History

#1 Updated by intrigeri over 5 years ago

  • Subject changed from add a nginx configuration sample for mirrors to Provide a nginx configuration sample for mirrors
  • Status changed from New to Confirmed
  • Type of work changed from Website to Documentation

Thanks. Anyone feeling like testing this?

#2 Updated by Anonymous over 5 years ago

It works here (I had to remove the “listen…” line since I already have another vhost).

#3 Updated by intrigeri over 5 years ago

hytails wrote:

It works here (I had to remove the “listen…” line since I already have another vhost).

Thank you. I think the "I already have another vhost" case is the general case, so the sample configuration should probably just drop the listen stanzy.

Do you mean it works for running a live Tails mirror, or anything else? (If anything else, please clarify, so that I know what level of confidence we can put into this file :)

#4 Updated by Anonymous over 5 years ago

It works for running a tor mirror. I'm currently setting up one.

#5 Updated by Anonymous over 5 years ago

A tails* mirror. Sorry for the mistake.

#6 Updated by intrigeri over 5 years ago

  • Status changed from Confirmed to Resolved

Thanks everyone, added to the documentation.

#7 Updated by sajolida over 5 years ago

  • Category changed from Infrastructure to 214

#8 Updated by BitingBird almost 5 years ago

  • Category changed from 214 to Infrastructure

Also available in: Atom PDF