Project

General

Profile

Bug #6885

Feature #5479: Bridge support

Feature #5920: Tor bridges support: complete phase one

Picking a non-English locale breaks bridge mode

Added by anonym almost 6 years ago. Updated over 1 year ago.

Status:
Resolved
Priority:
Elevated
Assignee:
-
Category:
-
Target version:
Start date:
03/07/2014
Due date:
% Done:

100%

Feature Branch:
bugfix/6885-tor-launcher-localisation
Type of work:
Research
Blueprint:
Starter:
No
Affected tool:

Description

Just test by selecting (seemingly) any non-English language in Tails Greeter.

History

#1 Updated by intrigeri almost 6 years ago

  • Subject changed from Picking a non-English locale breaks bridge mode. to Picking a non-English locale breaks bridge mode
  • Parent task set to #5920

#2 Updated by intrigeri over 5 years ago

That's apparently a known issue upstream.

#3 Updated by anonym over 5 years ago

  • Status changed from Confirmed to In Progress
  • Assignee changed from anonym to intrigeri
  • % Done changed from 0 to 80
  • QA Check set to Ready for QA
  • Feature Branch set to bugfix/6885-tor-launcher-localisation

I've pushed a fix in the bugfix/6885-tor-launcher-localisation Tails Git branch but since the fix is confined to Tor Launcher, also see our Tor Launcher repo. My tests are positive for all locales I tested it on: English (default), Chinese and German (translated), Bosnian and Turkish (not translated, so should fallback to English).

The short story is that XUL translation is pretty fragile and easily results in fatal errors like this for out-dated translations.

The long story can be read here, where I also go into some detail for an upstream fix.

#4 Updated by intrigeri over 5 years ago

  • Status changed from In Progress to 11
  • Assignee deleted (intrigeri)
  • % Done changed from 80 to 100

Merged, after one more code/review cycle.

#5 Updated by anonym over 5 years ago

  • Status changed from 11 to Resolved

#6 Updated by intrigeri over 1 year ago

  • QA Check deleted (Ready for QA)

Also available in: Atom PDF