Project

General

Profile

Feature #6878

Pressing Enter in Tails Installer should start the installation

Added by intrigeri almost 6 years ago. Updated 12 months ago.

Status:
Confirmed
Priority:
Low
Assignee:
-
Category:
Installation
Target version:
-
Start date:
03/07/2014
Due date:
% Done:

0%

Feature Branch:
Type of work:
Code
Blueprint:
Starter:
Yes
Affected tool:
Installer

Description

It would be good, on a system with a single possible target device, if pressing "Enter" would trigger the same action as clicking the "Install" button.

The code lives in the liveusb-creator Git repository. This work should be based on the master branch.

Presumably a simple change in the data/liveusb-creator.ui file (possibly by editing it with Qt Designer) would be enough.


Related issues

Related to Tails - Feature #15292: Distribute a USB image Resolved 04/14/2016 01/29/2019

History

#1 Updated by BitingBird almost 5 years ago

  • Affected tool set to Installer

#2 Updated by intrigeri over 4 years ago

Better base any work on this on the feature/jessie branch (in our liveusb-creator Git repo), and test it in an experimental Tails/Jessie ISO.

#3 Updated by emmapeel over 3 years ago

A user in tails-support had problems to install because the screen was too small. Maybe this feature will help on this issue, or maybe I should add a new ticket about it.

https://mailman.boum.org/pipermail/tails-support/2016-August/000621.html

#4 Updated by intrigeri over 3 years ago

A user in tails-support had problems to install because the screen was too small. Maybe this feature will help on this issue, or maybe I should add a new ticket about it.

Please clarify what the issue this user is having is exactly and then I hope it'll be easier to find what the relevant ticket is :)

#5 Updated by emmapeel over 3 years ago

The user could not see the Install Tails button because the screen of the device was too small. Also hitting Tab and Enter didn't worked, not moving the Tails installer window.

Nevertheless, there was a big black space on the message window in the middle of the Tails installer.

Maybe it could be done so we can make better use of the space.

#6 Updated by u over 2 years ago

The problem with the screen resolution issue seems unrelated to what this ticket is about.

#7 Updated by u over 1 year ago

#8 Updated by u over 1 year ago

  • Priority changed from Normal to Low

That would be nice to have, but we have nobody to work on it → lowering prio.

#9 Updated by u 12 months ago

  • Status changed from Confirmed to Rejected

Tails Installer will soon be removed from Debian → rejecting.

#10 Updated by u 12 months ago

  • Status changed from Rejected to Confirmed

Oops, I think we'll keep the installer for cloning, so rejecting was a bit premature!

Also available in: Atom PDF