Project

General

Profile

Feature #6877

Research how the check for upgrades could require less RAM

Added by intrigeri over 5 years ago. Updated 6 months ago.

Status:
Rejected
Priority:
Low
Assignee:
-
Category:
-
Target version:
-
Start date:
03/07/2014
Due date:
% Done:

0%

Feature Branch:
Type of work:
Research
Blueprint:
Starter:
No
Affected tool:
Upgrader

Description

It might be that the initial check for available memory (in the shell wrapper) uses overly conservative settings. Otherwise, porting the whole things from Moose to Moo (doable on Wheezy) or Moops (doable on Jessie, with a couple backports) might help.


Related issues

Related to Tails - Feature #6876: Have the incremental upgrade process use less RAM In Progress 03/07/2014
Related to Tails - Feature #10115: Add a splash screen to Tails persistence assistant Rejected 08/28/2015

History

#1 Updated by intrigeri over 4 years ago

  • Description updated (diff)

#2 Updated by intrigeri about 4 years ago

Memory::Usage is now in sid, which should help.

#3 Updated by intrigeri about 4 years ago

  • Related to Feature #10115: Add a splash screen to Tails persistence assistant added

#4 Updated by intrigeri about 1 year ago

I've successfully ported tails-persistence-setup from Moose to Moo + Function::Parameters. It would be good to measure how it affected its RAM consumption (Tails 3.8 vs. 3.9) and if it makes a relevant difference, then I should consider porting the Upgrader as well.

#5 Updated by u about 1 year ago

  • Priority changed from Low to Normal

Somebody seems to be working on this → setting priority to normal.

#6 Updated by intrigeri about 1 year ago

  • Priority changed from Normal to Low

#7 Updated by intrigeri 6 months ago

  • Status changed from Confirmed to Rejected
  • Assignee deleted (intrigeri)

Given we'd like to replace our Upgrader with a better, non-NIH solution, I don't think that it's a good use of our time to port it to a new set of dependencies now.

Also available in: Atom PDF