Project

General

Profile

Feature #6763

Include nautilus-gtkhash

Added by alant almost 6 years ago. Updated over 5 years ago.

Status:
Resolved
Priority:
Normal
Assignee:
-
Category:
-
Target version:
Start date:
02/24/2014
Due date:
% Done:

80%

Feature Branch:
feature/6763-include-nautilus-gtkhash
Type of work:
Code
Blueprint:
Starter:
No
Affected tool:

Description

nautilus-gtkhash is a "nautilus extension for computing checksums and more using"

"The GtkHash extension for nautilus which allows users to compute message digests or checksums using the mhash library. Currently supported hash functions include MD5, MD6, SHA1, SHA256, SHA512, RIPEMD, TIGER and WHIRLPOOL."

It is available in wheezy debian repositories

History

#1 Updated by sajolida almost 6 years ago

Are you proposing this with a particular core use case of Tails in mind? Or just as a additional general-purpose crypto tool?

#2 Updated by bertagaz almost 6 years ago

Could say both: it might be useful for people willing to use one of our nightly builds, as the ISO verification process implies to verify its hash.

A simple app to help people verifying hashes in Tails is potentially an interesting feature anyway, if they want to verify the integrity of software or whatever data they downloaded. This is a widely used way of doing that.

#3 Updated by intrigeri over 5 years ago

  • Type of work changed from Code to Discuss

Added to the agenda for the April meeting, so that we decide something eventually. It would be good if the proponents of this proposal provided the needed data beforehand, e.g. how much it adds to the ISO size, existing alternatives (if any) and why this one was chosen, testing reports...

#4 Updated by intrigeri over 5 years ago

  • Status changed from Confirmed to New
  • Type of work changed from Discuss to Code

#5 Updated by sajolida over 5 years ago

  • Status changed from New to Confirmed
  • Type of work changed from Code to Discuss

Since we'll talk about it in the April meeting, let's move it to Discuss, and away from New.

#6 Updated by sajolida over 5 years ago

  • Subject changed from Please include nautilus-gtkhash to Include nautilus-gtkhash

#7 Updated by intrigeri over 5 years ago

  • Type of work changed from Discuss to Code

The feature seems sound to have in Tails, and there is apparently no
alternative in Debian. nautilus-gtkhash seems well maintained in
Debian, has been tested on Tails/Wheezy, and installing it in there
only requires to download 89kB of .deb's.

So, at the monthly meeting we decided to install it in Tails 1.1.

#8 Updated by alant over 5 years ago

  • % Done changed from 0 to 50
  • Feature Branch set to feature/6763-include-nautilus-gtkhash

#9 Updated by alant over 5 years ago

  • % Done changed from 50 to 70
  • QA Check set to Ready for QA

#10 Updated by alant over 5 years ago

  • Status changed from Confirmed to In Progress

#11 Updated by alant over 5 years ago

  • QA Check changed from Ready for QA to Dev Needed

The documentation is curently missing. I'll draft something.

#12 Updated by alant over 5 years ago

  • Assignee changed from alant to sajolida
  • % Done changed from 70 to 80

I drafted some documentation. Assigning to sajolida for review.

#13 Updated by sajolida over 5 years ago

  • Assignee changed from sajolida to anonym
  • QA Check changed from Dev Needed to Ready for QA

Doc is ready.

#14 Updated by anonym over 5 years ago

  • Status changed from In Progress to 11
  • Assignee deleted (anonym)
  • QA Check changed from Ready for QA to Pass

Merged!

#15 Updated by BitingBird over 5 years ago

  • Status changed from 11 to Resolved

Also available in: Atom PDF