Project

General

Profile

Feature #6742

Make tor-controlport-filter reusable

Added by winterfairy almost 6 years ago. Updated almost 3 years ago.

Status:
Resolved
Priority:
Normal
Assignee:
-
Category:
-
Target version:
Start date:
02/21/2014
Due date:
% Done:

100%

Feature Branch:
feature/7870-include_onionshare
Type of work:
Code
Blueprint:
Starter:
Yes
Affected tool:

Description

We want to modify "tor-controlport-filter" so that the listening port and paths to the control port socket and authentication cookie can be passed in as commandline arguments, overriding the defaults.

This would make it possible for other projects similar to Tails to reuse this control port filter.

The best way to do this seems to be using the "argparse" module that was introduced in Python 2.7. This will be possible when Tails is based on Wheezy, and that will happen soon enough that using the deprecated "optparse" module available in Python 2.6 is not worth the implementation effort.


Related issues

Related to Tails - Feature #9001: Onion Circuits should connect via the Tor control port filter Resolved 03/03/2015
Related to Tails - Feature #6788: Use stem in the filtering proxy for the Tor control port Resolved 05/27/2014
Blocked by Tails - Feature #6015: Tails based on Wheezy Resolved 07/28/2013
Blocked by Tails - Feature #6384: Filtering proxy for the Tor control port Resolved 10/21/2013
Blocked by Tails - Feature #11542: Evaluate using roflcoptor as Tor control port filter Resolved 06/23/2016
Blocked by Tails - Feature #11826: Evaluate using Whonix' control-port-filter-python as Tor control port filter Resolved 09/22/2016
Blocked by Tails - Feature #7870: Include OnionShare Resolved 12/07/2016

Associated revisions

Revision 66b8e6bf (diff)
Added by anonym about 3 years ago

Make tor-controlport-filter reusable.

I.e. make it possible to pass the listen port, and Tor control
cookie/socket paths as arguments.

Will-fix: #6742

Revision 1a3c62b9
Added by intrigeri almost 3 years ago

Merge remote-tracking branch 'origin/feature/7870-include_onionshare' into devel

Fix-committed: #7870, #6742, #6788, #9001

History

#1 Updated by winterfairy almost 6 years ago

  • Starter changed from No to Yes

#2 Updated by intrigeri over 5 years ago

  • Subject changed from Commandline arguments for tor-controlport-filter to Make tor-controlport-filter reusable

#3 Updated by BitingBird almost 5 years ago

  • Category set to Tor configuration

#4 Updated by intrigeri almost 5 years ago

  • Category deleted (Tor configuration)

#5 Updated by BitingBird over 4 years ago

winterfairy, do you want to do that? The blockers have been solved :)

#6 Updated by intrigeri over 4 years ago

Note that Whonix folks have forked this script and changed it quite a bit, see corresponding discussion about it (February or March, IIRC) on tails-dev@. Some of their changes indeed make the script more generic and reusable. Some others are very much disputable.

#7 Updated by intrigeri over 4 years ago

Also see Yawning's Go implementation: https://github.com/yawning/or-ctl-filter

#8 Updated by intrigeri almost 4 years ago

  • Related to Feature #9001: Onion Circuits should connect via the Tor control port filter added

#9 Updated by intrigeri almost 4 years ago

#10 Updated by intrigeri almost 4 years ago

#12 Updated by sajolida almost 4 years ago

  • Related to Feature #6788: Use stem in the filtering proxy for the Tor control port added

#13 Updated by sajolida almost 4 years ago

David Stainton also wrote a "bidirectional tor control port filter", see https://github.com/david415/or-ctl-sieve.

Subgraph OS also need something like this. They are considering also writing a D-Bus interface to it.

#14 Updated by sajolida over 3 years ago

Also, from the Subgraph report from April:

@david415 is writing a Tor control port filter to mitigate risks to security and anonymity introduced sharing the control port from a single Tor client instance.

Code:

https://github.com/subgraph/roflcoptor

#15 Updated by sajolida over 3 years ago

roflcoptor seems to be the successor of or-ctl-sieve according to the Acknowledgements in https://github.com/subgraph/roflcoptor.

#16 Updated by sajolida over 3 years ago

  • Blocked by Feature #11542: Evaluate using roflcoptor as Tor control port filter added

#17 Updated by intrigeri about 3 years ago

  • Blocked by Feature #11826: Evaluate using Whonix' control-port-filter-python as Tor control port filter added

#18 Updated by anonym about 3 years ago

  • Status changed from Confirmed to In Progress

#19 Updated by intrigeri about 3 years ago

  • Assignee set to anonym
  • Target version set to Tails 2.10
  • Feature Branch set to feature/7870-include_onionshare

(Looks like everything required by this ticket is done as part of #7870 :)

#20 Updated by intrigeri about 3 years ago

#21 Updated by intrigeri about 3 years ago

#22 Updated by intrigeri about 3 years ago

  • Related to deleted (Feature #8173: Make Ricochet usable in Tails)

#23 Updated by anonym almost 3 years ago

  • Assignee changed from anonym to intrigeri
  • QA Check set to Ready for QA

#24 Updated by intrigeri almost 3 years ago

  • Status changed from In Progress to 11
  • % Done changed from 0 to 100

#25 Updated by intrigeri almost 3 years ago

  • Assignee deleted (intrigeri)
  • QA Check changed from Ready for QA to Pass

#26 Updated by anonym almost 3 years ago

  • Status changed from 11 to Resolved

Also available in: Atom PDF