Project

General

Profile

Feature #6739

Add Electrum bitcoin client to Tails

Added by winterfairy over 5 years ago. Updated over 4 years ago.

Status:
Resolved
Priority:
Normal
Assignee:
-
Category:
-
Target version:
Start date:
10/20/2014
Due date:
% Done:

100%

Feature Branch:
feature/6739-install-electrum
Type of work:
Code
Blueprint:
Starter:
No
Affected tool:

Description

There seem to be some new interest in including a light-weight
Bitcoin client in Tails.

Electrum is one such client that does not require downloading
any of the blockchain, and therefore should work well in
live systems like Tails. There are other benefits as well, see:

https://electrum.org/

Electrum need to be backported to Wheezy for this to happen:

https://mailman.boum.org/pipermail/tails-dev/2014-February/004860.html

More information can be found in the
"Adding BitMessage and Bitcoin-QT to Tails" thread on tails-dev
posted in February 2014.

I filed this ticket so it is not forgotten.
I set it to "discuss" since I couldn't tell if a decision had been reached.


Subtasks

Feature #8163: Write user documentation for ElectrumResolved


Related issues

Blocked by Tails - Feature #6015: Tails based on Wheezy Resolved 07/28/2013
Blocked by Tails - Bug #8091: Support automated testing of old ISO images with different set of persistence presets Resolved 10/13/2014

Associated revisions

Revision 69e52e3a
Added by Tails developers over 4 years ago

Merge branch 'feature/6739-install-electrum' into devel

Fix-committed: #6739

History

#1 Updated by winterfairy over 5 years ago

Usage instructions from ForgottenBeast:

./electrum -s 56ckl5obj37gypcu.onion:50001:t -p socks5:localhost:9050

"pretty straightforward, I'm using Electrum 1.7.4 in a persistent
folder. I run after connecting to tor. It takes usually a bit before
it connects but nothing surprising since its through tor. iirc there
are other electrum hidden services one can connect to."

#2 Updated by intrigeri over 5 years ago

  • Type of work changed from Discuss to Wait

At the monthly meeting, we decided to wait and see if someone interested enough backports this package for Wheezy. If and when this happens, then Tails users can install it (and add it with the Additional Software feature), and we can possibly discuss installing it by default.

#3 Updated by sajolida almost 5 years ago

  • Type of work changed from Wait to Discuss

It seems like there is a backport available now:

https://packages.debian.org/wheezy-backports/electrum

Time to move this forward? Anybody wants to test it and report? Any discussion still needs to take place?

#4 Updated by intrigeri almost 5 years ago

IMO, this should become a low priority "Code" ticket, indeed. Adding support for persisting the Electrum wallet (and whatever is needed to get a working environment back after rebooting) seems to be a must have for merging a branch that installs Electrum, though: the recover wallet from 12 memorized words feature is great, but I don't think we can rely purely on it to provide a nice Bitcoin user-experience using Electrum.

#5 Updated by BitingBird almost 5 years ago

  • Type of work changed from Discuss to Code

#6 Updated by anonym almost 5 years ago

  • Status changed from Confirmed to In Progress
  • Target version set to Tails_1.2
  • % Done changed from 0 to 50
  • QA Check set to Ready for QA
  • Feature Branch set to feature/6739-install-electrum

I prepared something like a week ago which I fixed up today and pushed. Optimistically targeting for Tails 1.2 but I won't hold my breath. :)

For me it passes the automated test suite's usb_intsall.feature test, which indicates that the persistence preset is working.

#7 Updated by BitingBird almost 5 years ago

To be merged it will have to be documented in the design document, the user documentation, and the FAQ will have to be changed also (didn't look if/what of that has been done, just listing the places I think about).

#8 Updated by anonym almost 5 years ago

BitingBird wrote:

To be merged it will have to be documented in the design document, the user documentation, and the FAQ will have to be changed also (didn't look if/what of that has been done, just listing the places I think about).

Thanks! I've added user docs for the new persistence preset now, and a blurb in the design docs.

However, since this is just an optional, non-essential piece of software, do we really have to block its inclusion by not having any further user docs? We install tons of similarly "marginal" software without any user documentation. Otherwise, are any of the following two tutorials good enough to link to?

Also, IMHO, for anyone familiar with the basic Bitcoin concepts, the setup wizard and interface makes using it a no-brainer.

#9 Updated by BitingBird almost 5 years ago

anonym wrote:

Thanks! I've added user docs for the new persistence preset now, and a blurb in the design docs.

Great!

However, since this is just an optional, non-essential piece of software, do we really have to block its inclusion by not having any further user docs? We install tons of similarly "marginal" software without any user documentation.

Well, since lots of users ask for it, I think it's a bit more than marginal: it's not a system software, users are going to use it intentionnaly. I don't think we have to re-make documentation ourselves, but it should be listed in https://tails.boum.org/doc/about/features/index.en.html, and there should be a short page in https://tails.boum.org/doc/anonymous_internet/electrum with the link(s) to documentation - otherwise, looooooots of users are going to ask for help on irc/mail.

Otherwise, are any of the following two tutorials good enough to link to?

Since I never used bitcoins, I have no idea if they are good, but I trust you and if we give both links, each user can follow the documentation they like :)

Also, https://tails.boum.org/support/faq/index.en.html#index21h2 at the end, the "bitcoin, electrum: see ticket #6739" line should be removed.

#10 Updated by sajolida almost 5 years ago

  • Assignee set to anonym
  • QA Check changed from Ready for QA to Info Needed

Yes, let's try to have a comprehensive documentation. Especially for
such a popular request. I think that all the software with a GUI that we
recently added to /doc/about/features had a documentation when we merged
them. Some on that list don't but they were added a while ago.

But that documentation really doesn't have to be long, see
/doc/sensitive_documents/office_suite. So I'll look at the links that
you already sent us but please provide me with information about
anything specific to Tails for this software. I don't mind writing it.
And that can be done after the freeze.

#11 Updated by intrigeri almost 5 years ago

  • Target version changed from Tails_1.2 to Tails_1.3

#12 Updated by anonym almost 5 years ago

sajolida wrote:

Yes, let's try to have a comprehensive documentation.

Ok. I added #8163, assigned it to you.

Note that I've force-pushed a new version of the branch, since the old one must have been based on a devel/testing that diverged from what's pushed now, or something. All previous commits are identical, and I've pushed a new one that adds a wrapper that warns about using Electrum while persistence is disabled, since it could lead to loss of the wallet.

#13 Updated by intrigeri almost 5 years ago

  • QA Check changed from Info Needed to Dev Needed

This will need to be rebased once the branch for #8091 is merged.

#14 Updated by intrigeri almost 5 years ago

  • Blocked by Bug #8091: Support automated testing of old ISO images with different set of persistence presets added

#15 Updated by intrigeri over 4 years ago

We might be affected by https://bugs.debian.org/775269 and https://bugs.debian.org/764138. Should be fixed once 1.9.8-4 reaches testing, and is backported for Wheezy.

#16 Updated by anonym over 4 years ago

  • Assignee deleted (anonym)
  • QA Check deleted (Dev Needed)

intrigeri wrote:

This will need to be rebased once the branch for #8091 is merged.

Done, branch was force pushed. The only changes were:

  • New section number in desgin doc due to a conflict with the new sections for wget and apt.
  • Dropped the two persistence-related automated test suite commits that now are much more elegantly solved thanks to #8091.

We might be affected by https://bugs.debian.org/775269 and https://bugs.debian.org/764138. Should be fixed once 1.9.8-4 reaches testing, and is backported for Wheezy.

I cannot reproduce this in Tails with electrum 1.9.8-1~bpo70+1 (the current wheezy backport); both account creation and restoring from a seed Just Works, and it doesn't matter if I use our default ~/.electrum or not.

I think we're only blocked by the lack of user docs now (#8163).

#17 Updated by anonym over 4 years ago

  • QA Check set to Ready for QA

#18 Updated by bertagaz over 4 years ago

  • Assignee set to bertagaz
  • QA Check deleted (Ready for QA)

#19 Updated by bertagaz over 4 years ago

  • QA Check set to Ready for QA

#20 Updated by Tails over 4 years ago

  • Status changed from In Progress to Fix committed

Applied in changeset commit:d8253cad6a111c6ebc209912008382455a655a54.

#21 Updated by bertagaz over 4 years ago

  • Assignee deleted (bertagaz)
  • QA Check changed from Ready for QA to Pass

#22 Updated by BitingBird over 4 years ago

  • Status changed from Fix committed to Resolved

Also available in: Atom PDF