Project

General

Profile

Feature #6728

Feature #5919: Incremental upgrades

Feature #6508: incremental upgrades: complete phase four

Check for upgrades a bit later

Added by intrigeri almost 6 years ago. Updated almost 6 years ago.

Status:
Resolved
Priority:
Normal
Assignee:
-
Category:
-
Target version:
Start date:
02/18/2014
Due date:
% Done:

100%

Feature Branch:
feature/6508-incremental-upgrades-phase-four
Type of work:
Code
Blueprint:
Starter:
No
Affected tool:
Upgrader

Description

First, it seems that at the time we check for available upgrades, Tor is not always 100% ready.
Second, we run many things in parallel at session startup, and in some cases we are not able to check for upgrades due to memory exhaustion.


Related issues

Duplicated by Tails - Bug #6784: Make sure Tails Upgrader runs once Tor is usable Duplicate 02/26/2014

Associated revisions

Revision 463388f4 (diff)
Added by Tails developers almost 6 years ago

Wait for Tor to have fully bootstrapped before checking for upgrades (partly closes: #6728).

Revision cf2a191c (diff)
Added by Tails developers almost 6 years ago

Wait 30 more seconds after Tor has bootstrapped, before checking for upgrades (Closes: #6728).

We run many things in parallel at session startup, and in some cases we are not
able to check for upgrades due to memory exhaustion. Waiting a bit might help.

History

#1 Updated by intrigeri almost 6 years ago

  • Status changed from Confirmed to In Progress
  • % Done changed from 0 to 10

#2 Updated by intrigeri almost 6 years ago

  • Status changed from In Progress to Resolved
  • Assignee deleted (intrigeri)
  • % Done changed from 10 to 100

Done, will ask review'n'merge globally.

#3 Updated by BitingBird over 5 years ago

  • Duplicated by Bug #6784: Make sure Tails Upgrader runs once Tor is usable added

Also available in: Atom PDF