Project

General

Profile

Bug #6570

Feature #7409: Browse the offline documentation using Yelp

Yelp freezes while searching the offline Tails documentation

Added by mercedes508 over 5 years ago. Updated about 1 year ago.

Status:
Rejected
Priority:
Normal
Assignee:
-
Category:
-
Target version:
-
Start date:
01/05/2014
Due date:
% Done:

0%

Feature Branch:
Type of work:
Test
Blueprint:
Starter:
Yes
Affected tool:

Description

When using the search feature of the offline documentation, the pointer disappear from the screen and the offline doc seems to be freezing for a few seconds.

The pointer shouldn't be disappearing, at least in order to allow user to do something else.


Related issues

Related to Tails - Bug #14962: Tor Browser >= 7.0.8 fails to render local pages correctly Resolved 11/16/2017
Related to Tails - Feature #6569: Make the Tails documentation searchable offline Confirmed 01/05/2014

History

#1 Updated by intrigeri over 5 years ago

This is clearly a bug in yelp (the GNOME help browser). Next step is to try and reproduce this on a Wheezy build.

#2 Updated by intrigeri over 5 years ago

  • Status changed from New to Confirmed

#3 Updated by BitingBird over 4 years ago

  • Type of work changed from Research to Test

#4 Updated by intrigeri over 4 years ago

  • Starter changed from No to Yes

This can easily be tested in current Tails.

#5 Updated by hybridwipe almost 4 years ago

I think the documentation changed, this is fixed, or I'm missing something :).

In 1.4.1, going to Applications > Tails > Tails Documentation launches the offline documentation in the Tor Browser. There is no search feature in the documentation itself, and searching in DuckDuckGo works fine if internet is connected, and (obviously) fails with internet disabled.

#6 Updated by sajolida almost 4 years ago

  • Status changed from Confirmed to Resolved

Same here. The offline documentation opens in the browser. Using the search bar in Yelp (Accessories → Help) takes "no" time.

Marking this as resolved then. Thanks hybridwipe for helping us closing this!

#7 Updated by mercedes508 almost 4 years ago

Oops, apparently I forgot to mention when creating that ticket that it was about Tails offline doc, not the yelp one - if I remember well enough.

But there's no more search engine in Tails offline doc, so that ticket is obsolete anyway.

#8 Updated by intrigeri almost 4 years ago

  • Status changed from Resolved to Confirmed

Title: Yelp freezes while searching the offline Tails documentation

At least in theory, using the web browser for offline Tails documentation was a workaround caused by various Yelp bugs, and that ideally we would like to go back to Yelp (long-term, low-priority goal): #7409. So this ticket is useful (although not very clearly defined) to track one of the blockers. So I'm reopening it, adjusting title, and making it a subtask of #7409.

#9 Updated by intrigeri almost 4 years ago

  • Subject changed from Freeze during search in the offline doc to Yelp freezes while searching the offline Tails documentation
  • Parent task set to #7409

#10 Updated by intrigeri almost 4 years ago

  • Priority changed from Low to Normal

#11 Updated by sajolida over 1 year ago

  • Related to Bug #14962: Tor Browser >= 7.0.8 fails to render local pages correctly added

#12 Updated by sajolida about 1 year ago

  • Related to Feature #6569: Make the Tails documentation searchable offline added

#13 Updated by sajolida about 1 year ago

  • Status changed from Confirmed to Rejected

We won't use Yelp, see #7409#note-10.

Also available in: Atom PDF