Project

General

Profile

Feature #6565

Feature #5288: Run the test suite automatically on autobuilt ISOs

Run the test suite automatically on Git push

Added by intrigeri over 5 years ago. Updated over 3 years ago.

Status:
Duplicate
Priority:
Normal
Assignee:
-
Category:
Continuous Integration
Target version:
Start date:
01/03/2014
Due date:
10/15/2015
% Done:

0%

QA Check:
Feature Branch:
Type of work:
Sysadmin
Blueprint:
Starter:
No
Affected tool:

Description

Once we have a platform to run the automated test suite, we can plug it into our Jenkins setup to run it automatically on autobuild ISO images.

Based on the results of #8667:

  • write library code that implements the (successful Jenkins ISO build job -> if/what needs to be tested) mapping;
  • research and quickly try out the various options available to implement the specified needs with Jenkins; the deliverable is a blueprint comparing these options, proposing a design, and finally leading the discussion towards a decision;
  • implement the chosen design.

Zuul might be useful for this.


Related issues

Blocked by Tails - Feature #6564: Deploy a platform for automated testing Resolved
Blocked by Tails - Feature #8667: Lead a discussion to specify what automatically build ISOs needs to be tested, when and how Resolved 01/10/2015 07/15/2015

History

#1 Updated by bertagaz over 4 years ago

  • Blocked by Feature #8667: Lead a discussion to specify what automatically build ISOs needs to be tested, when and how added

#2 Updated by bertagaz over 4 years ago

  • Target version changed from Hardening_M1 to Tails_1.6

#4 Updated by intrigeri almost 4 years ago

  • Description updated (diff)
  • Assignee set to bertagaz

#5 Updated by intrigeri almost 4 years ago

  • Due date set to 10/15/2015

#6 Updated by bertagaz over 3 years ago

  • Assignee changed from bertagaz to intrigeri
  • QA Check set to Info Needed

Isn't that a bit of a duplicate of #5288?

#7 Updated by intrigeri over 3 years ago

  • Assignee changed from intrigeri to bertagaz

Isn't that a bit of a duplicate of #5288?

Indeed. Assuming all child tickets of #5288 are part of the same deliverable, feel free to kill #6565.

#8 Updated by bertagaz over 3 years ago

  • Status changed from Confirmed to Duplicate
  • Assignee deleted (bertagaz)
  • QA Check deleted (Info Needed)

Duplicate of its parent.

Also available in: Atom PDF