Project

General

Profile

Feature #6564

Feature #5288: Run the test suite automatically on autobuilt ISOs

Deploy a platform for automated testing

Added by intrigeri almost 6 years ago. Updated over 4 years ago.

Status:
Resolved
Priority:
Elevated
Assignee:
-
Category:
Continuous Integration
Target version:
Start date:
Due date:
% Done:

90%

Feature Branch:
Type of work:
Sysadmin
Blueprint:
Starter:
No
Affected tool:

Description

Allow Tails core developers to run, on our infrastructure, the Tails automated test suite on ISO images that are already being automatically built there.


Related issues

Blocks Tails - Feature #6565: Run the test suite automatically on Git push Duplicate 01/03/2014 10/15/2015
Blocked by Tails - Feature #7631: Get a server able to run our automated test suite Resolved 01/01/2015

History

#1 Updated by sajolida almost 6 years ago

  • Subject changed from Deploy a platform for automated testing of Tails to Deploy a platform for automated testing

#2 Updated by intrigeri over 5 years ago

  • Assignee set to bertagaz

#3 Updated by intrigeri over 5 years ago

  • Blocked by Feature #7631: Get a server able to run our automated test suite added

#5 Updated by sajolida about 5 years ago

  • Target version changed from Hardening_M1 to Tails_1.3

Set the target version to 1.3 (February 17) since this blocks #8117.

#6 Updated by sajolida about 5 years ago

  • Target version changed from Tails_1.3 to Tails_1.3.2

#7 Updated by sajolida over 4 years ago

  • Priority changed from Normal to Elevated

I'm concerned to see that this ticket has been postponed for the fourth time. Take into account that this is blocking a funders' deliverable (#8117) and cannot be postponed anymore this time. So marking this as Elevated.

#8 Updated by intrigeri over 4 years ago

  • Status changed from Confirmed to In Progress
  • % Done changed from 0 to 50

Last remaining thing to do: document how Tails core devs can use what's been set up. Probably not worth a subticket, I guess.

#9 Updated by bertagaz over 4 years ago

  • Assignee changed from bertagaz to intrigeri

Wrote a first attempt, please review/complete it.

https://tails.boum.org/contribute/release_process/test/usage/on_lizard

#10 Updated by intrigeri over 4 years ago

  • Status changed from In Progress to Resolved
  • Assignee deleted (intrigeri)
  • % Done changed from 50 to 100

Reviewed, reworked quite a bit => I'm now happy with it. Calling this task done, congrats!

#11 Updated by intrigeri over 4 years ago

  • Status changed from Resolved to In Progress
  • Assignee set to bertagaz
  • % Done changed from 100 to 90

Actually, the new feature and instructions were not announced to core devs yet, and they won't magically discover it => reopening.

#12 Updated by bertagaz over 4 years ago

  • Assignee changed from bertagaz to intrigeri

Right, good catch, just sent an email to the Tails private mailing list.

#13 Updated by intrigeri over 4 years ago

  • Status changed from In Progress to Resolved
  • Assignee deleted (intrigeri)

Yay!

#14 Updated by BitingBird over 4 years ago

  • Target version changed from Tails_1.3.2 to Tails_1.3.1

Also available in: Atom PDF