Project

General

Profile

Bug #6552

Feature #5421: Spoof MAC address

Correctly detect when MAC address was not spoofed on NICs that macchanger cannot get the permanent MAC of

Added by intrigeri about 6 years ago. Updated almost 6 years ago.

Status:
Resolved
Priority:
Normal
Assignee:
-
Category:
Spoof MAC
Target version:
Start date:
12/30/2013
Due date:
% Done:

100%

Feature Branch:
feature/spoof-mac
Type of work:
Code
Blueprint:
Starter:
No
Affected tool:

Description

Details are in the report sent by intrigeri to tails-dev on 2013-12-27.

As anonym put it, we'd need to save the MAC address to somewhere in the
filesystem in tails-spoof-mac (called by the MAC spoof udev hook)
since we also need the functionality of nic_has_spoofed_mac() in the
fails-safe in tails-unblock-network.

History

#1 Updated by anonym almost 6 years ago

  • Status changed from Confirmed to In Progress
  • Assignee changed from anonym to intrigeri
  • QA Check set to Ready for QA
  • Feature Branch set to feature/spoof-mac

Fixed in commit b32d80d.

#2 Updated by intrigeri almost 6 years ago

  • Status changed from In Progress to 11
  • Assignee deleted (intrigeri)
  • % Done changed from 0 to 100
  • QA Check changed from Ready for QA to Pass

#3 Updated by intrigeri almost 6 years ago

  • Status changed from 11 to Resolved

Also available in: Atom PDF