Project

General

Profile

Feature #6533

Mention I2P in "About" page

Added by sajolida almost 6 years ago. Updated over 1 year ago.

Status:
Resolved
Priority:
Elevated
Assignee:
-
Category:
-
Target version:
Start date:
12/23/2013
Due date:
% Done:

100%

Feature Branch:
doc/6533-about_i2p
Type of work:
End-user documentation
Blueprint:
Starter:
No
Affected tool:
I2P

Description

Our current "About" page does not mention I2P. It might be ok to not mention it on the homepage but it should be briefly introduces in the "Online anonymity" of the "About" page, as an alternative to Tor. Not everything goes through Tor, I2P does not.

Associated revisions

Revision 6f72a201
Added by Tails developers almost 5 years ago

Merge remote-tracking branch 'bitingbird/doc/6533-about_i2p'

Closes: #6533

Revision afb5536a
Added by sajolida over 4 years ago

Merge branch 'doc/6533-about_i2p' (Closes: #6533)

History

#1 Updated by sajolida almost 6 years ago

  • Assignee deleted (kytv)

#2 Updated by BitingBird almost 5 years ago

This section is named "Online anonymity and censorship circumvention with Tor". Should I rename it, or put the information somewhere else ?

#3 Updated by sajolida almost 5 years ago

We should try to rename that section as "Online anonymity and censorship circumvention", still mention Tor as the main and default option. But mention I2P as an alternative at the end.

I could be worth checking with the I2P homepage or kytv whether I2P can be called a tool to "circumvent censorship". I guess it definitely can in some way.

#4 Updated by kytv almost 5 years ago

IMHO it could be classified as a tool to "circumvent censorship" though mostly in the same way that Tor's "hidden services" can.

I2P can also be used as an "exit" to the internet via volunteer-run "outproxies" but this functionality is disabled in Tails. I (in Tails' hook scripts) remove the default outproxies "false.i2p" and "outproxy-tor.meeh.i2p" from the tunnel configuration. An interested user could easily add these or any other outproxy to their tunnel configuration(s) if desired for whatever reason, but even without the outproxies I think the description "censorship circumvention" could be used.

#5 Updated by BitingBird almost 5 years ago

  • Assignee set to BitingBird
  • Target version set to Tails_1.3.2

#6 Updated by BitingBird almost 5 years ago

  • Status changed from Confirmed to In Progress
  • % Done changed from 0 to 30
  • Feature Branch set to bitingbird:doc/6533-about_i2p

Pushed something, I still have to build.

The mention is minimal, since we already have a dedicated page.

#7 Updated by BitingBird almost 5 years ago

  • Assignee changed from BitingBird to sajolida
  • Target version changed from Tails_1.3.2 to Tails_1.3
  • QA Check set to Ready for QA

Built, looks good.

#8 Updated by BitingBird almost 5 years ago

  • Priority changed from Normal to Elevated

The change is small, review could be quick :)

#9 Updated by intrigeri almost 5 years ago

  • Assignee changed from sajolida to intrigeri

#10 Updated by Tails almost 5 years ago

  • Status changed from In Progress to Resolved
  • % Done changed from 30 to 100

Applied in changeset commit:fc85021ba61684ac05093ff8d601e1fda1e51955.

#11 Updated by intrigeri almost 5 years ago

  • Status changed from Resolved to In Progress
  • Assignee changed from intrigeri to sajolida
  • % Done changed from 100 to 50
  • Feature Branch changed from bitingbird:doc/6533-about_i2p to doc/6533-about_i2p

I've merged current master into the topic branch and added a few commits on top. Now, I'm wondering whether it's relevant to write "To learn more about I2P, see the official I2P website" on our "about" page: the previous sentence links to our I2P doc, that itself links to the I2P website. Shall we just drop that sentence?

#12 Updated by sajolida over 4 years ago

  • Target version changed from Tails_1.3 to Tails_1.3.2

I think this needs more work. For example, I'm not happy with having I2P mentioned at the very end of a long section about Tor without any hint about it before (either in the intro or in the structure). Remember that people don't read on the web, they scan.

Still, I want to do a more constructive review but I won't be able to do it in time for 1.3, so I'm postponing to 1.3.1.

#13 Updated by Tails over 4 years ago

  • Status changed from In Progress to Resolved
  • % Done changed from 50 to 100

#14 Updated by intrigeri over 4 years ago

  • Status changed from Resolved to In Progress
  • % Done changed from 100 to 50

#15 Updated by BitingBird over 4 years ago

what happened ? It says "Applied" but it's not

#16 Updated by intrigeri over 4 years ago

what happened ? It says "Applied" but it's not

Someone (probably me) mistakenly used "Closes:" when merging your work into doc/6533-about_i2p in the official repo, so the Redmine/Gitolite integration thing thought it has been resolved. Otherwise, the current status of this ticket seems correct to me.

#17 Updated by sajolida over 4 years ago

  • Status changed from In Progress to Resolved
  • % Done changed from 50 to 100

#18 Updated by sajolida over 4 years ago

  • Assignee deleted (sajolida)

#19 Updated by BitingBird over 4 years ago

  • Target version changed from Tails_1.3.2 to Tails_1.3.1

#20 Updated by intrigeri over 1 year ago

  • QA Check deleted (Ready for QA)

Also available in: Atom PDF