Project

General

Profile

Bug #6531

Feature #6015: Tails based on Wheezy

Fix Unsafe Browser vs. APT

Added by intrigeri over 5 years ago. Updated over 5 years ago.

Status:
Resolved
Priority:
Normal
Assignee:
Category:
-
Target version:
Start date:
12/23/2013
Due date:
% Done:

0%

Feature Branch:
Type of work:
Code
Blueprint:
Starter:
No
Affected tool:

Description

The Unsafe Browser does not start as:

# apt-get remove  xul-ext-*
Reading package lists... Done
E: The value 'wheezy' is invalid for APT::Default-Release as such a release is not available in the sources

This is presumably due to not shipping APT lists.

Replacing this call with something like that should work:

dpkg -l 'xul-ext-*' | /bin/grep '^ii' | awk '{print $2}' | xargs echo dpkg --remove

Associated revisions

Revision 1db7d445 (diff)
Added by Tails developers over 5 years ago

Don't try to use APT to remove packages in the Unsafe Browser script (Closes: #6531).

History

#1 Updated by intrigeri over 5 years ago

  • Status changed from Confirmed to Resolved

Fixed in 54d6ae7.

Also available in: Atom PDF