Project

General

Profile

Feature #6505

Feature #5919: Incremental upgrades

Feature #6508: incremental upgrades: complete phase four

Hide the details of IUK errors by default

Added by sajolida about 6 years ago. Updated almost 6 years ago.

Status:
Resolved
Priority:
Normal
Assignee:
-
Category:
-
Target version:
Start date:
12/17/2013
Due date:
% Done:

100%

Feature Branch:
feature/6508-incremental-upgrades-phase-four
Type of work:
Code
Blueprint:
Starter:
No
Affected tool:
Upgrader

Description

The technical details of the error will be of little use for most user. It is mainly displayed to be copy & pasted for debugging purpose. So we should hide it by default and have a expandable area and a "Show technical details" button or similar.

But at least for a while, such errors should be reported as a bug. It will be nicer this way once this code is tested more
broadly, that is, after it is enabled by default, and most bugs are fixed.

Let’s implement this once such errors will be more likely to be caused by issues on the user's side (e.g. network problems) than by bugs in our software.

History

#1 Updated by intrigeri about 6 years ago

  • Status changed from New to Confirmed
  • Parent task set to #6508

#2 Updated by intrigeri about 6 years ago

  • Assignee set to intrigeri
  • Target version set to Tails_0.23

#3 Updated by intrigeri almost 6 years ago

  • Status changed from Confirmed to In Progress
  • Feature Branch set to feature/6508-incremental-upgrades-phase-four

#4 Updated by intrigeri almost 6 years ago

  • % Done changed from 0 to 10

Implemented in Git by hiding debugging info, and pointing to ~/.xsession-errors.

#5 Updated by intrigeri almost 6 years ago

  • Status changed from In Progress to Resolved
  • Assignee deleted (intrigeri)
  • % Done changed from 10 to 100

Done, will ask review'n'merge globally.

Also available in: Atom PDF