Project

General

Profile

Feature #6474

Also use TorBrowser's mozconfig

Added by intrigeri almost 6 years ago. Updated over 5 years ago.

Status:
Resolved
Priority:
Normal
Assignee:
-
Category:
-
Target version:
Start date:
12/09/2013
Due date:
% Done:

100%

Feature Branch:
feature/6474-tor-browser-mozconfig
Type of work:
Code
Blueprint:
Starter:
No
Affected tool:
Browser

Description

The Tails browser's debian/rules sets MOZCONFIG to a Debian-specific one. Therefore, the .mozconfig installed by a TorBrowser patch is ignored. We should merge these somehow to be closer to TorBrowser.

See the mozconfig documentation.


Related issues

Related to Tails - Bug #6468: Disable WebRTC Resolved 12/08/2013

History

#1 Updated by intrigeri over 5 years ago

mozconfig files support inclusion using "."

In the two mozconfig files we would like to use, only one setting is obviously conflicting (--{enable,disable}-strip, since dh_strip takes care of this in the Debian package).

Looks doable!

#2 Updated by intrigeri over 5 years ago

  • Status changed from Confirmed to In Progress
  • % Done changed from 0 to 10

#3 Updated by intrigeri over 5 years ago

  • Feature Branch set to feature/6474-tor-browser-mozconfig

#4 Updated by intrigeri over 5 years ago

  • Status changed from In Progress to Fix committed
  • Assignee deleted (intrigeri)
  • % Done changed from 10 to 100

#5 Updated by anonym over 5 years ago

  • Status changed from Fix committed to Resolved

Also available in: Atom PDF