Project

General

Profile

Bug #6464

Stored cookies don't appear in Cookies window

Added by NeilBowers almost 6 years ago. Updated almost 2 years ago.

Status:
Resolved
Priority:
Normal
Assignee:
-
Category:
-
Target version:
-
Start date:
12/03/2013
Due date:
% Done:

0%

Feature Branch:
Type of work:
Wait
Blueprint:
Starter:
No
Affected tool:
Browser

Description

In Tails 0.22~rc1 the stored cookies don't appear in the Cookies window.
To recreate:
Access any site that will store a cookie, such as your login information.
From the top right of the TorBrowser or iceweasle click on Cookie Monster icon. It's on the far right, next to the Home icon.

Then select "View Cookies" -> "Show Cookies for All Sites"
Cookies window will open but it's empty even though the cookie is stored now.

History

#1 Updated by intrigeri almost 6 years ago

  • Target version deleted (Tails_0.22)

#2 Updated by NeilBowers almost 6 years ago

Won't this be fixed in time for 0.22? Problem didn't exist in 0.21.

#3 Updated by intrigeri almost 6 years ago

Won't this be fixed in time for 0.22?

If updates to Torbutton or to the TorBrowser patch set fix this, then
it'll be fixed. Else, it won't. Stay tuned.

I acknowledge this is an annoying regression, but it does not break
any of the Tails design goals, so I doubt it'll be treated with
high priority. Help is welcome :)

#4 Updated by sajolida almost 6 years ago

As far as I understand, this is a user experience regression, but it is an understood issue caused by an API change in Firefox 24. It is track by Tor on this ticket:

https://trac.torproject.org/projects/tor/ticket/10353

#5 Updated by intrigeri almost 6 years ago

  • Status changed from New to Confirmed
  • Type of work changed from Code to Upstream

#6 Updated by intrigeri almost 6 years ago

This seems to be Debian bug 738800

#8 Updated by intrigeri about 5 years ago

  • Type of work changed from Upstream to Wait

#9 Updated by intrigeri almost 5 years ago

See also https://trac.torproject.org/projects/tor/ticket/14632 ("Disable Cookie Manager until we get it working").

#11 Updated by u almost 2 years ago

  • Status changed from Confirmed to Resolved

Let's close this ticket as upstream has resolved the issue long time ago.

#12 Updated by intrigeri almost 2 years ago

Hmmm… well, the buggy window was removed, which indeed "solves" the problem, but does not give users the desired feature back. Anyway.

Also available in: Atom PDF